database connection error

Problems with the Windows version of XAMPP, questions, comments, and anything related.

database connection error

Postby paul de paula » 09. July 2005 09:06

thanks guys for sharing your ideas...but i have a problem in database connection using xampp.
i have installed xampp for a couple of weeks now and one of the problems that i've encountered is how to connect my php code to the database located in xampp/mysql/bin (filename.sql). after typing[mysql -u root -p <filename.sql] and it was sucessful. When i execute the code [theres a FATAL ERROR: CLASS 'MYSQLI' not found in C:apachefriends/xampp/htdocs/filename.php].

i hope anyone could help me with this problem, i would greatly appreciate it...im working with our school project. TNX
paul de paula
 
Posts: 3
Joined: 09. July 2005 08:47

Postby Wiedmann » 09. July 2005 13:04

When i execute the code [theres a FATAL ERROR: CLASS 'MYSQLI' not found in C:apachefriends/xampp/htdocs/filename.php].

This PHP extension is not enabled by default.

php.ini ("\xampp\apache\bin"):
extension=php_mysqli.dll
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby paul de paula » 10. July 2005 06:35

thanx!

i've allready do that, but the same error...the php.ini should be placed in xammp/apache/bin? in my case i put it in c:\windows...would it be ok if i put it there?
paul de paula
 
Posts: 3
Joined: 09. July 2005 08:47

Postby Wiedmann » 10. July 2005 09:07

the php.ini should be placed in xammp/apache/bin?

yes (must be placed there. and it's allready there)

in my case i put it in c:\windows...would it be ok if i put it there?

no
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 41 guests