MySQL Compatibility Problem

Problems with the Windows version of XAMPP, questions, comments, and anything related.

MySQL Compatibility Problem

Postby Massimo » 05. July 2005 20:08

Hello all

I am using shopping cart software called Cubecart. Having created the shop I have tried to export my sql file to the net database. When doing so I receive an error... Charset and Collate syntax not recognised.

The problem I think is that xampp is MySQL 4.1, an my host (oneandone.co.uk) uses MySQL 4.0. I have discovered that one of the refinement to 4.1 was that they changed the charset and collate syntax

Does anyone know how I can make it compatible?

All thoughts welcome

Many thanks, Massimo
Help :)
Massimo
 
Posts: 2
Joined: 05. July 2005 18:17

Postby Massimo » 06. July 2005 13:26

Sorted it. I found the drop down menu that changes it to 4.0 :-)
Help :)
Massimo
 
Posts: 2
Joined: 05. July 2005 18:17

Postby alucard01 » 06. July 2005 17:17

Just a thought:

Before installing CubeCart, you may require to create a DB in your MySQL first. In that moment, you can state your collation of this database to something like 'latin_general_ci' or sth...(coz I am using Chinese, I always setup my DB collation using this, and it seems to work...)

Hope it helps...
alucard01
 
Posts: 122
Joined: 15. May 2005 13:51


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 59 guests