changing DocumentRoot

Problems with the Windows version of XAMPP, questions, comments, and anything related.

changing DocumentRoot

Postby Henrik » 25. June 2005 19:02

I have changed DocumentRoot in apache/httpd.conf

When I enter http://localhost/home/index.html (home is a subdirectory of my site root directory), I get the correct web page, IOW the updated setting of the DocumentRoot is working.

HOWEVER

When I enter http://localhost into the browser (ie. the default "/" directory), it is NOT finding DocumentRoot, but rather the xampp root, so I end up with the recalculated address http://localhost/xampp/splash.php, and an "object not found" error, as my site structure does not have a xampp subdirectory.

I've tried spoofing all this -- creating a xampp subdirectory in my own site structure, with an index.html file renamed to splash.php, and that works, so I know apache is finding a directive to look for xampp/splash.php somewhere, and applying it to my DocumentRoot path.

Where is apache finding the directive to look for xampp/splash.php when responding to a request for the default "/" directory? How do I change this?

Thanks,

- Henrik
Henrik
 
Posts: 2
Joined: 25. June 2005 18:53

Postby Wiedmann » 25. June 2005 19:38

Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby Henrik » 25. June 2005 20:34

I cleared my browser cache and that fixed the problem. I gather this is quite a common problem: perhaps a note in the install notes??...

Thanks!

- Henrik
Henrik
 
Posts: 2
Joined: 25. June 2005 18:53


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 41 guests