dBase supoort in the XAMPP version of PHP

Problems with the Windows version of XAMPP, questions, comments, and anything related.

dBase supoort in the XAMPP version of PHP

Postby Slyder » 03. May 2005 21:36

Well the topic pretty much is the question. Does the compilied version of PHP with XAMPP have dBase support?

Thanks for the help.
Slyder
 
Posts: 3
Joined: 03. May 2005 21:32

Postby Wiedmann » 03. May 2005 22:09

The dBase extension is a shared library and you must enable it in the "php.ini".
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby Slyder » 03. May 2005 22:18

By enable do you mean uncomment it? like removing the ";"? I recieved an error when running the dBase functions such as "create_dbase()" and wondered if it was compilied into the build?
Slyder
 
Posts: 3
Joined: 03. May 2005 21:32

Postby Wiedmann » 03. May 2005 22:37

By enable do you mean uncomment it? like removing the ";"?

Yes.

and wondered if it was compilied into the build?

No. It's not compiled in, it's a shared extension (only shared extension you must enable in the php.ini).

I recieved an error when running the dBase functions such as "create_dbase()"

a) you have an error like: "i am at lunch, your PHP interpreter"...

b) there is no function "create_dbase()".
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby Slyder » 03. May 2005 23:06

I removed the comment ";"

I only asked if it was compiled due to the comment from http://us3.php.net/manual/en/ref.dbase.php where it says under installation that "you must compile PHP with the --enable-dbase option."

And as for the command, it's dbase_create() that I was using and recieved a "Fatal Error: Call to undefined function dbase_create()"

But thank you for your help.
Slyder
 
Posts: 3
Joined: 03. May 2005 21:32

Postby Wiedmann » 04. May 2005 09:51

I removed the comment ";"

And as for the command, it's dbase_create() that I was using and recieved a "Fatal Error: Call to undefined function dbase_create()"

You have made this change in the correct php.ini?
--> \xampp\apache\bin\php.ini

Don't forget to restart Apache.

I only asked if it was compiled due to the comment from http://us3.php.net/manual/en/ref.dbase.php where it says under installation that "you must compile PHP with the --enable-dbase option."

That's for Unix.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 55 guests