PHP.ini deafult directory

Problems with the Windows version of XAMPP, questions, comments, and anything related.

PHP.ini deafult directory

Postby crash75uk » 16. April 2005 19:58

I'm trying to change the php deault directory from it's default (C:\apachefriends\xampp\htdocs) to another part of my pc unsuccessfully.

Tried searching for the php.ini to change it but managed to find 11 php.ini file on my disc????

I'm using xampp.

So which one do i change and is it as simple as changing the doc root to
doc_root = "c:/bloody/thing/"?
crash75uk
 
Posts: 3
Joined: 16. April 2005 19:48

Postby Wiedmann » 16. April 2005 20:26

I'm trying to change the php deault directory from it's default (C:\apachefriends\xampp\htdocs) to another part of my pc unsuccessfully.

You mean your document_root?

That's a configuration option from Apache (httpd.conf) and not PHP (php.ini).
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby crash75uk » 16. April 2005 20:46

Did try editing the httpd.conf file first but that didn't seem to work, so assumed i was doing things wrong and tried the php.ini.

it current says

DocumentRoot "C:/Apache/htdocs"

but it the actual location php is running from is "C:\apachefriends\xampp\htdocs"

I originall edited this line and the <Directory "C:/Apache/htdocs"> line.
crash75uk
 
Posts: 3
Joined: 16. April 2005 19:48

Postby crash75uk » 16. April 2005 21:05

ok, looks like i edited the wrong httpd.conf file, but fixed that and still doesn't work with the correct httpd.conf file. and now my localhost has stopped working, aaargh.
crash75uk
 
Posts: 3
Joined: 16. April 2005 19:48


Return to XAMPP for Windows

Who is online

Users browsing this forum: Frag and 43 guests