stuck at the php.ini hurdle....

Problems with the Windows version of XAMPP, questions, comments, and anything related.

stuck at the php.ini hurdle....

Postby richk » 14. March 2005 10:38

newbie here - i've got everything up and running but am trying to get email working through php - it keeps saying that i haven't defined sendmail_from in php.ini.....i have though (in \apachefriends\xampp\apache\bin\php.ini which i think is the right one).....any ideas?

how can you alternatively set it up within the page's code - ini_set?

thanks
richk
 
Posts: 3
Joined: 14. March 2005 02:11

Postby Maller » 14. March 2005 13:04

You should be able to send mail with php, are you sure you configured it right ?
you could post your mail configuration here....
check phpinfo() for the right path to the php.ini
Did you restart apache after you changed php.ini ?
If you for some reason you cant get it to work, witch you really should, you can always use the pear mail class
http://pear.sourceforge.net/manual/core.mail.smtp.php
User avatar
Maller
 
Posts: 49
Joined: 06. March 2004 14:47

Postby richk » 14. March 2005 14:37

thanks for the reply

this is how i configured it; the php.ini file is as per the path specified in phpinfo. which is why i stumped? is there anything else i need to do below, or do i have to move the php.ini file any other than where it is
(apachefriends\xampp\apache\bin\php.ini)

------------------------------------------------------------------------------------

[mail function]
; For Win32 only.
SMTP = smtp.homecall.co.uk

; For Win32 only.
sendmail_from =richard.king@homecall.co.uk

------------------------------------------------------------------------------------
richk
 
Posts: 3
Joined: 14. March 2005 02:11

Postby richk » 14. March 2005 23:30

sussed it now thanks before anybody else replies!
richk
 
Posts: 3
Joined: 14. March 2005 02:11

Postby joannew » 16. March 2005 21:30

How did you fix this, I have exactly the same problem. Current php.ini entries are:

[mail function]
; For Win32 only.
SMTP = localhost

; For Win32 only.
sendmail_from =richard.king@homecall.co.uk #(my own email address)
User avatar
joannew
 
Posts: 3
Joined: 16. March 2005 21:23
Location: Wales

Postby taustin » 17. March 2005 00:13

joannew wrote:How did you fix this, I have exactly the same problem. Current php.ini entries are:

[mail function]
; For Win32 only.
SMTP = localhost

; For Win32 only.
sendmail_from =richard.king@homecall.co.uk #(my own email address)


Those settings should work. You do have to restart Apache for them to take effect. Are you sure the mail server is running on localhost?
taustin
 
Posts: 150
Joined: 24. September 2004 00:23
Location: Huntington Beach CA

Postby joannew » 17. March 2005 15:17

No. How do I check?
User avatar
joannew
 
Posts: 3
Joined: 16. March 2005 21:23
Location: Wales

Postby taustin » 17. March 2005 17:58

joannew wrote:No. How do I check?


If you didn't start Mercury, it isn't running. It doesn't run automatically by default.
taustin
 
Posts: 150
Joined: 24. September 2004 00:23
Location: Huntington Beach CA


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 71 guests