CGI script error, please help

Problems with the Windows version of XAMPP, questions, comments, and anything related.

CGI script error, please help

Postby dobbelina » 14. March 2005 10:20

Hi !
I just installed the "XAMPP Windows 1.4.12" package on my
Windows Xp computer and it works fine except for one detail.

When i try to run one of my cgi scripts i get a error 500.

"The server encountered an internal error or misconfiguration and was unable to complete your request."
In the error log it says like this:

[Mon Mar 14 15:57:57 2005] [error] [client 127.0.0.1] Premature end of script headers: backupsmanager.cgi
[Mon Mar 14 15:57:58 2005] [error] [client 127.0.0.1] Can't locate CGI.pm in @INC (@INC contains: .) at D:/minixampp/xampp/cgi-bin/backupsmanager.cgi line 826.\r
[Mon Mar 14 15:57:58 2005] [error] [client 127.0.0.1] BEGIN failed--compilation aborted at D:/minixampp/xampp/cgi-bin/backupsmanager.cgi line 826.\r


I have put in the right path (#!D:\minixampp\xampp\perl\bin\perl.exe)
in the script but i still get this error ?

I then tried another cgi script that supposedly should help to give all the right pathes, but then i get this error:
[Mon Mar 14 16:13:19 2005] [error] [client 127.0.0.1] (OS 3)The system cannot find the path specified. : couldn't create child process: 720003: searcher.cgi
[Mon Mar 14 16:13:20 2005] [error] [client 127.0.0.1] (OS 3)The system cannot find the path specified. : couldn't spawn child process: D:/minixampp/xampp/cgi-bin/searcher.cgi


It's strange cause the "perltest.cgi" script seems to work fine.
When i click it in the browser it says:
GCI with MiniPerl
CGI with MiniPerl is ready ...

Do i have to have the Perl 1.4.12 addon installed for this to work or
is it a configuration issue ?
dobbelina
 
Posts: 17
Joined: 14. March 2005 09:33

Postby dobbelina » 15. March 2005 06:10

Please can someone help me out with this one ?
I ran those two scripts yesterday and forgot to put in the "path" to
the second script (not the first one), but i still get a similar error
message in the error log file.
This:

[Tue Mar 15 11:18:26 2005] [error] [client 127.0.0.1] Premature end of script headers: searcher.cgi
[Tue Mar 15 11:18:26 2005] [error] [client 127.0.0.1] Can't locate CGI.pm in @INC (@INC contains: .) at D:/minixampp/xampp/cgi-bin/searcher.cgi line 92.\r
[Tue Mar 15 11:18:26 2005] [error] [client 127.0.0.1] BEGIN failed--compilation aborted at D:/minixampp/xampp/cgi-bin/searcher.cgi line 92.\r


Do i need to install the "Perl 1.4.12" addon ?
This is really confusing, cause i have that "miniperl" installed.
When going thru the httpd.conf file all the parameters for running cgi
scripts are there. (original configuration, nothing changed)
(if you wonder about the "minixammp" folder,it's not the lite version
installed, i only put it there from a previous lite version so i don't need to
change the script paths in some of my php scripts).
PLEASE Someone, gimme a hand por favor ! :lol:
dobbelina
 
Posts: 17
Joined: 14. March 2005 09:33

Postby dobbelina » 16. March 2005 07:24

dobbelina
 
Posts: 17
Joined: 14. March 2005 09:33


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 52 guests