CGI - BIN

Problems with the Windows version of XAMPP, questions, comments, and anything related.

CGI - BIN

Postby thekingofcaseys » 10. March 2005 23:48

I have a referal script that require installtion from inside the CGI BIN i have placed all files and folder on my server as hey shoud be and then i am asked to call the location of the file, therefore i am going to http://localhost/cgi-bin.referer.pl.

However on doing this i get internal server error do i have to do something to be able to use the cgi bin any help would be great
thekingofcaseys
 
Posts: 50
Joined: 27. December 2004 15:38

Re: CGI - BIN

Postby petitprince » 10. March 2005 23:56

thekingofcaseys wrote:I have a referal script that require installtion from inside the CGI BIN i have placed all files and folder on my server as hey shoud be and then i am asked to call the location of the file, therefore i am going to http://localhost/cgi-bin.referer.pl.

However on doing this i get internal server error do i have to do something to be able to use the cgi bin any help would be great


- First of all, the correct url would be http://localhost/cgi-bin/referer.pl not ... cgi-bin.referer.pl.

- Did you download and install the Perl-AddOn for XAMPP at all?

- Finally you might have to set the path to Perl within the script correctly.

petitprince
petitprince
 
Posts: 74
Joined: 10. January 2005 22:31

Postby thekingofcaseys » 11. March 2005 11:17

Ok i got the path to the script correct that was simply a mistype, No i have not added any add on mods and if i need to set a path how would this be done, any help would be appreciated. and i have just installed the perl mod add on for xampp and configured it to use mod perl i place those file in the cgi bin and tried again and got this

Code: Select all
Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, admin@localhost and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.


--------------------------------------------------------------------------------

Apache/2.0.53 (Win32) PHP/5.0.3 mod_ssl/2.0.53 OpenSSL/0.9.7e mod_perl/1.999.21 Perl/v5.8.6 Server at localhost Port 80
thekingofcaseys
 
Posts: 50
Joined: 27. December 2004 15:38

Postby thekingofcaseys » 11. March 2005 11:55

Hey petitprince thanks just those few simple thing enabled me to work it out installed the addon, configured it set my script to point to the perl.exe whola! all fixed.

Bet you cant answer this question looking for a mail server smtp to relay emails from the site, must be free do you know of any
thekingofcaseys
 
Posts: 50
Joined: 27. December 2004 15:38

Postby thekingofcaseys » 11. March 2005 12:35

One more upate the script that i am running require the sendemail programme not it tells me it need the unix path however im on windows if i put the windows path a dos box comes and goes same with the unix path should this fuction still work, or would it be disabled
thekingofcaseys
 
Posts: 50
Joined: 27. December 2004 15:38

Postby petitprince » 11. March 2005 16:15

thekingofcaseys wrote:Hey petitprince thanks just those few simple thing enabled me to work it out installed the addon, configured it set my script to point to the perl.exe whola! all fixed.

Bet you cant answer this question looking for a mail server smtp to relay emails from the site, must be free do you know of any


Hi 'thekingofcaseys',

glad you found out by yourself how to set the path to perl in your script! :-) - For the mail server: I am not using a mail server on my machine, but isn't there one included in XAMPP? - Just look for "Mercury Mail" in your local XAMPP pages, you should find a few instructions there ...

Sorry for your last message, but I simply do not understand it, I am not a native English speaker and - uhm - it would really make things easier for me if you cared a bit about punctuation (no offense intended) ... ;-)

petitprince
petitprince
 
Posts: 74
Joined: 10. January 2005 22:31

Postby prathapml » 12. March 2005 00:45

thekingofcaseys wrote: a mail server smtp to relay emails from the site, must be free
Gmail offers 1 GB of mailbox space to you as a user. It also offers free POP3/SMTP mail.

Server: smtp.gmail.com
port: 465
Need to authenticate - not an open relay.

http://gmail.google.com

If you don't yet have a Gmail account, you need to know someone that DOES, to send you an invitation to register.
prathapml
 
Posts: 87
Joined: 11. March 2005 23:03

Postby thekingofcaseys » 17. March 2005 16:02

I have Gmail Already And Over 300 Invitations if anyone wants some, Im unable to use SMTP server for Gmail as it requires authorisation and my IPB does not offer this option on the email settings. Thanks anyway.
thekingofcaseys
 
Posts: 50
Joined: 27. December 2004 15:38

Postby prathapml » 17. March 2005 16:19

IPB? :?
prathapml
 
Posts: 87
Joined: 11. March 2005 23:03

Postby petitprince » 17. March 2005 19:18

thekingofcaseys wrote:I have Gmail Already And Over 300 Invitations if anyone wants some, Im unable to use SMTP server for Gmail as it requires authorisation and my IPB does not offer this option on the email settings. Thanks anyway.


Ah, now I get it! :-) - Well, what is the problem with authorisation? - This is usually not a problem of your Internet Service Provider (ISP (= IPB (?)), but with the provider of the SMTP server ... Could you elaborate a bit which problem you exactly have with authentification?

petitprince
petitprince
 
Posts: 74
Joined: 10. January 2005 22:31

Help Again

Postby thekingofcaseys » 29. May 2005 11:31

Hey guys as you know i actually repaird this error the first time aroun but i just tried to install again and im getting errors does anyone know the full path to perl im using the latest version of xampp and its installed in it default location c:/apachefriend

could you please tell me the full relative path to perl and also do my scripts go in the cgi-bin thats there or would i need to create one in my website root
thekingofcaseys
 
Posts: 50
Joined: 27. December 2004 15:38


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 61 guests