Problems with the Windows version of XAMPP, questions, comments, and anything related.


Postby ajfarren » 09. March 2005 16:49

Hi all.

I have installed the latest xampp onto an xpsp2 machine with success. The splash/phpmyadmin/etc.. all work fine.

When I tried to make a simple php page with Wordperfect, save it to htdocs(as an ASII text, and DOS text with .php extension), it did not work (page not found error). I assumed that it was because it was M$ adding in things that were not supposed to be there. So I tried again with notepad, making a simple phpinfo() page, saving it to htdocs, and browsing to it in IE; and still it did not work. When I browsed to the files I made in Windoze Explorer it looked like they were just text files, even though they had the php extension, even the icons were different than the other php files that come with the Xampp installation.

I had used notepad in another xampp install on a ME machine, and it seemed to work fine. Does anyone know of any issues with XP and/or SP2 and notepad that may cause this? Do I need to use an independant editor?

Thanks very much for any info anyone may provide. :D

Posts: 2
Joined: 09. March 2005 15:56

Postby taustin » 09. March 2005 17:59

This is Microsoft stupidity. The default behavior on XP (and most other versions of Windows) is to add the program's default extension to the end of file names, and not show you the extension. So when you use Save As in Notepad, and type in "stuff.php", it will save it as "stuff.php.txt", but when you look in Explorere, it only shows "stuff.php."

You can bypass this behavior on a file by file basis by putting the file name in quote marks in the Save As box. The quote marks will tell Windows to not screw with the extension.

To get Explorer to work correctly, open up any Explorer windows - My Computer, for instance - and go to the Tools menu, and open up the Folder Options. Click on the View tab, and find the entry for "Hide extensions for known file types." Uncheck it, and click Apply. From that point on, you should see the entire file name. You can then rename the existing files without the .txt extension.

Microsoft is run by idiots.
Posts: 150
Joined: 24. September 2004 00:23
Location: Huntington Beach CA


Postby ajfarren » 10. March 2005 04:18

Hey thanks for the quick reply and for the fix. Linux here I come!

Posts: 2
Joined: 09. March 2005 15:56

Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 36 guests