Upgrade or downgrade php in XAMPP

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Upgrade or downgrade php in XAMPP

Postby reggiep » 04. March 2005 21:47

I am trying to work out if it is possible to upgrade or downgrade php in XAMPP.
Why i here you ask. Well I am running a Virtual Learning Environment in my School called Moodle. Now this has a backup and restore feature and it doesn't work with the version of php I have on the server.
Is it possible to do this ?


Posts: 2
Joined: 04. March 2005 21:37

Postby Wiedmann » 04. March 2005 21:51

AF Moderator
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby reggiep » 06. March 2005 21:55

Hi Wiedmann,
Thanks for the reply. Could you please elaborate a bit more please?
I have found the batch file, what do I need to do to use it?


Posts: 2
Joined: 04. March 2005 21:37

Postby Dave_L » 06. March 2005 22:25

If you run that .bat file, it will switch PHP between 4.x and 5.x.
User avatar
Posts: 212
Joined: 23. October 2004 00:43


Postby frankec2000 » 07. March 2005 10:19


I had a similar problem have run the php switch and now the backup and restore work's.

So if anyboby else has this problem just to inform you that the modules work and have tested them and they seem to be okay.

Their is ment to be a update for this bug but I am waiting for the next apachefriends update.
Find this program to be a real asset.
thank for brilliant product.

Posts: 4
Joined: 07. January 2005 12:37

Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 32 guests