Xampp control panel

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Xampp control panel

Postby Kroesss » 01. March 2005 16:16

Hi, I just updated from Xampp 1.4.11 to 1.4.12 with the zip-download (the 1.4.11 was a fresh install, also zip-version). Everything works smooth, but there is one weird thing. When I try to start the Mysql using the new control-panel it immediatly jumps back to status "stopped", the rest (apache, filezilla and mercury) run perfect with the control panel, but I have to start the Mysql using the mysql_start.bat file. Stopping mysql through the control-panel is working well.
Kroesss
 
Posts: 35
Joined: 18. November 2004 09:08
Location: Vriezenveen

Postby Ron! » 02. March 2005 09:06

:idea: mysql_installservice.bat i think thats what its call :?:
:arrow: but run that its in the mysql folder :wink:
Ron!
 
Posts: 3
Joined: 28. February 2005 20:18

Postby Kroesss » 02. March 2005 11:23

I'm running Xampp as a tool to test new scripts for websites, otherwise I have to upload the files everytime I change something, now I can test it locally. I don't have apache or mysql installed as service because of that, I want to start and stop them without having to install it as service, is that possible.
Kroesss
 
Posts: 35
Joined: 18. November 2004 09:08
Location: Vriezenveen

Postby bobobo » 02. March 2005 11:54

check your my.cnf (in xampp/mysql/bin)
especially the ports
User avatar
bobobo
 
Posts: 19
Joined: 12. December 2003 10:22
Location: 89275

Postby Kroesss » 02. March 2005 19:01

I don't recall making any changes to all this, but here it is, I don't see anything wrong with it, but then again: I'n not an expert by a long shot on this...

Code: Select all
# The MySQL client
[client]
# password       = your_password
port            = 3306
socket          = mysql

# Here follows entries for some specific programs

# The MySQL server
[mysqld]
old-passwords
port            = 3306
socket          = mysql
skip-locking
# default-character-set=utf8
character-set-server = latin1
collation-server = latin1_general_ci
key_buffer = 16M
max_allowed_packet = 1M
table_cache = 256
sort_buffer_size = 1M
read_buffer_size = 1M
read_rnd_buffer_size = 4M
net_buffer_length = 8K
myisam_sort_buffer_size = 64M
# log-bin
server-id       = 1
thread_cache = 8

basedir=C:/xampp/mysql
tmpdir=C:/xampp/tmp
datadir=C:/xampp/mysql/data

#bind-address=192.168.1.1
#log-update     = /path-to-dedicated-directory/hostname

# Uncomment the following if you are using BDB tables
#set-variable   = bdb_cache_size=4M
#set-variable   = bdb_max_lock=10000

skip-innodb
# Uncomment the following if you are using InnoDB tables
#innodb_data_home_dir = C:/xampp/mysql/
#innodb_data_file_path = ibdata1:10M:autoextend
#innodb_log_group_home_dir = C:/xampp/mysql/
#innodb_log_arch_dir = C:/xampp/mysql/
# You can set .._buffer_pool_size up to 50 - 80 %
# of RAM but beware of setting memory usage too high
#set-variable = innodb_buffer_pool_size=16M
#set-variable = innodb_additional_mem_pool_size=2M
# Set .._log_file_size to 25 % of buffer pool size
#set-variable = innodb_log_file_size=5M
#set-variable = innodb_log_buffer_size=8M
#innodb_flush_log_at_trx_commit=1
#set-variable = innodb_lock_wait_timeout=50

[mysqldump]
quick
max_allowed_packet=16M

[mysql]
no-auto-rehash
# Remove the next comment character if you are not familiar with SQL
#safe-updates

[isamchk]
set-variable    = key_buffer=20M
set-variable    = sort_buffer=20M
set-variable    = read_buffer=2M
set-variable    = write_buffer=2M

[myisamchk]
set-variable    = key_buffer=20M
set-variable    = sort_buffer=20M
set-variable    = read_buffer=2M
set-variable    = write_buffer=2M

[mysqlhotcopy]
interactive-timeout

[WinMySQLadmin]
Server=C:/xampp/mysql/bin/winmysqladmin.exe
Kroesss
 
Posts: 35
Joined: 18. November 2004 09:08
Location: Vriezenveen

Postby Kroesss » 05. March 2005 17:43

anyone see anything wrong?
Kroesss
 
Posts: 35
Joined: 18. November 2004 09:08
Location: Vriezenveen

Postby bobobo » 07. March 2005 15:00

that looks like mine, excepting the datapaths :roll:
User avatar
bobobo
 
Posts: 19
Joined: 12. December 2003 10:22
Location: 89275

Postby Kroesss » 08. March 2005 18:19

So there's isn't anything wrong with it...

Anybody any other ideas why it won't start mysql?
Kroesss
 
Posts: 35
Joined: 18. November 2004 09:08
Location: Vriezenveen

Postby prathapml » 12. March 2005 00:27

No idea why it won't, but I suggest you install the MySQL daemon as a service, if its under Win2k/XP. Then it should start fine, and you can still stop it thru xampp CPL.


Also, try upgrading to version 2.0 of the CPL - the bundled version is 1.4.x
prathapml
 
Posts: 87
Joined: 11. March 2005 23:03

Postby Kroesss » 13. March 2005 13:48

I only se Xampp control panel 1.0 in the downloadablke packages. Can someone give me a link to the 2.0-version?

I'd like to try the nw CPL first, before running mysql as a service.
Kroesss
 
Posts: 35
Joined: 18. November 2004 09:08
Location: Vriezenveen

Postby prathapml » 13. March 2005 14:09

http://www.nat32.com/xampp/

XAMPP CPL 2.1 - Enjoy!
prathapml
 
Posts: 87
Joined: 11. March 2005 23:03

Postby Kroesss » 16. March 2005 19:16

OK, installed the new CP (nice!) but the mysql still won't work smoothly. I installed it as a service, didn't do the trick either. I'm afriad I'm going to have to wait till the next xampp-update unless anyone has an idea?
Kroesss
 
Posts: 35
Joined: 18. November 2004 09:08
Location: Vriezenveen

Postby prathapml » 16. March 2005 20:06

Well, starting it using the batch-file is working you say?
Then why not try this:

1. Stop mysql fully, first.
2. Go into "\xampp\mysql\" folder.
3. run the .BAT file that uninstalls the service.
4. run the .BAT file that installs the service.
Should work now... If it doesn't, then there's a problem with your "my.cnf" file.


If the problem is with the "my.cnf", then I suggest you download the 7zip version of XAMPP, and extract the default "my.cnf" from it. Repleace yours with the default file.

Do post back on how it goes. :)
prathapml
 
Posts: 87
Joined: 11. March 2005 23:03

Postby Kroesss » 19. March 2005 10:42

prathapml wrote:Well, starting it using the batch-file is working you say?
Then why not try this:

1. Stop mysql fully, first.
2. Go into "\xampp\mysql" folder.
3. run the .BAT file that uninstalls the service.
4. run the .BAT file that installs the service.
Should work now...


This works, but the mysql is now started automaticly when I switch on my computer. Since I use Xampp for local testing of webpages, I don't want it on for most of the times. Is there a way to have mysql turned off by standard, and starting when asked through the control panel?
Kroesss
 
Posts: 35
Joined: 18. November 2004 09:08
Location: Vriezenveen

Postby prathapml » 19. March 2005 17:59

Run that .BAT to install the service when you want to run it.
Then run the uninstall .BAT when you want to stop it.
Simple now?
prathapml
 
Posts: 87
Joined: 11. March 2005 23:03


Return to XAMPP for Windows

Who is online

Users browsing this forum: JJ_Tagy and 70 guests