phpmyadmin versions

Problems with the Windows version of XAMPP, questions, comments, and anything related.

phpmyadmin versions

Postby Kroesss » 22. February 2005 12:50

I'm currently running Xampp 1.4.11, whitch comes with phpmyadmin 2.6.0-pl3. Now I want to update to Xampp 1.4.12 (with phpmyadmin 2.6.1), but when I look at the things included in the update package, I don't see the 2.6.1-version of phpmyadmin. Do I have to update the phpmyadmin manually or is it in the package, but just forgotten on the list.
Kroesss
 
Posts: 35
Joined: 18. November 2004 09:08
Location: Vriezenveen

Postby Wiedmann » 22. February 2005 13:14

Do I have to update the phpmyadmin manually or is it in the package, but just forgotten on the list.

Sorry, it's forgotten in the upgrade package... :?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby Kroesss » 22. February 2005 14:29

What's the best thing to do? Install Xampp from scratch or is it possible to get a get instruction how to update phpmyadmin myself?
Kroesss
 
Posts: 35
Joined: 18. November 2004 09:08
Location: Vriezenveen

Postby Wiedmann » 22. February 2005 14:42

You can do this yourself:

a) save the file "config.inc.php" ("\xampp\phpmyadmin")
b) delete all files in "\xampp\phpmyadmin"
c) extract the new phpMyAdmin into "\xampp\phpmyadmin"
d) replace the file "config.inc.php" ("\xampp\phpmyadmin") with the previous saved one
e) enable the PHP extension "mbstring" in "php.ini" ("\xampp\apache\bin"): extension=php_mbstring.dll
f) restart Apache
g) go to http://localhost/phpmyadmin/ --> have fun
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby Kroesss » 22. February 2005 14:49

Great, I'll try it when I get home. Looks like I should be able to do this myself :)
Kroesss
 
Posts: 35
Joined: 18. November 2004 09:08
Location: Vriezenveen

Postby sNiXx » 22. February 2005 18:10

worked perfectly fine (after I realized that it wouln't work until I restarted it)

thanks
sNiXx
 
Posts: 8
Joined: 21. February 2005 21:18
Location: Schweiz

Postby Kroesss » 22. February 2005 18:30

Just applied the upgrade and the manual upgrade of phpmyadmin. Completely no errors!

Thanks Wiedmann!!!
Kroesss
 
Posts: 35
Joined: 18. November 2004 09:08
Location: Vriezenveen

Postby Tony_P » 09. March 2005 14:45

I noticed in the latest buil 2.61 PL3 they have changed a line in the inc file and added this,

$cfg['Servers'][$i]['AllowRoot'] = TRUE; // whether to allow root login

Is this line actually neccisary? I ask because when added and usin g the cookie log in you get an Access denied by root@ locahost.
Tony_P
Tony_P
 
Posts: 15
Joined: 02. February 2005 15:29

Postby Tony_P » 09. March 2005 19:38

Got it working thanx anyways
Tony_P
Tony_P
 
Posts: 15
Joined: 02. February 2005 15:29


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 34 guests