IMAP doesn´t work.

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Postby Knappe » 18. February 2005 22:18

Hi Haaima

Code: Select all
If I understand it correctly you removed de semicolon in the php.ini.
The next step is to add the following line into your httpd.conf.
PHPIniDir "F:\apachefriends\xampp\php".
Change the path to your own.
Place the above line just under the following line.
AddType application/x-httpd-php .php .php4 .php3 .phtml
This should do the trick.


This doesn´t work.
If I pointed with PHPIniDir to ?:\xampp\apache\bin (where my php.ini files resides) OR to ?:xampp\php-5.0.3 : in both cases I became the error-messages from the Apache-Server "Could not found the file Secure32.dll"".... and "cannot load dynamic link library php_imap.dll".

Any other ideas ?
Knappe
 
Posts: 114
Joined: 18. November 2004 17:40

Postby Wiedmann » 18. February 2005 22:52

"Could not found the file Secure32.dll"

You mean "Secur32.dll"?

This file is part of your Windows installation and is stored in "%windir%\system32". This directory should be in your system environment search path.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby Knappe » 18. February 2005 23:00

Code: Select all
This file is part of your Windows installation and is stored in "%windir%\system32".


Ja, schön wäre es .. ist aber nicht (dir c:\secur32.dll /S ergibt : nichts).

Im Übrigen : Dieser Fehler tritt beim Starten vom Apache erst dann auf, wenn ich in der php.ini die Zeile extension=php_imap.dll auskommentiere (da ich die imap-Funktion gerade jetzt benötige).

Win NT 4 SP 6, Apache-Version 2.048, PHP-Version 5.0.3
Knappe
 
Posts: 114
Joined: 18. November 2004 17:40

Postby Wiedmann » 18. February 2005 23:12

Ja, schön wäre es .. ist aber nicht (dir c:\secur32.dll /S ergibt : nichts).

Than you have a problem with your windows. Try the system file checker (sfc.exe).
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby Knappe » 18. February 2005 23:58

Code: Select all
sfc.exe

doesn´t exist in my Win NT System.

Any idea ?
Knappe
 
Posts: 114
Joined: 18. November 2004 17:40

Postby Knappe » 19. February 2005 01:19

I found the solution :

Under Windows NT you hav to copy the file "security.dll" to "secur32.dll" in the c:\..\system32 - directory.

Then the Apache is starting normal including the php_imap-modul !
Knappe
 
Posts: 114
Joined: 18. November 2004 17:40


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 66 guests