Any hints on getting 'Bloxsom' Blog s/w on XAMPP win2k ?

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Any hints on getting 'Bloxsom' Blog s/w on XAMPP win2k ?

Postby gregInHuntingtonBeachCA » 17. February 2005 22:58

02/17/2005 @ 1:53 PM PST

Hi to the group from USA...

A few days ago I got XAMPP up & running on my laptop aok... (great stuff -- Thanks for such a great bundle).

Anyway - I use the s/w called Bloxsom (which is a 1-way blog) for keeping track of to do items that I am workign on.

Cant seem to get this 'cgi' working with the out of the box configuraiton of XAMPP. I have tried a number of reasonable things such as altering the http.conf file for apache, altering fwd slashes to back slaches (in Bloxsom) & such. No luck.. Always see the old "INTERNAL SERVER ERROR" in my webpage when I try to hit local bloxsom site.

Of note the perltest & cgi.cgi code does work aok...

Anyone from the roup have any hints on things to try next.

Thanks very much in advance.

Cheers GregH (greg.Huddleston@citigroup.com)
TIA GregH
gregInHuntingtonBeachCA
 
Posts: 4
Joined: 17. February 2005 22:49

Postby Wiedmann » 17. February 2005 23:10

"INTERNAL SERVER ERROR"

error.log?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

well more info on whats 'really' going on with this from

Postby gregInHuntingtonBeachCA » 18. February 2005 00:15

hi again (I am the poster of this thread)

Here is more of whats 'really' going on with this...
I have found the apache&friendsversion of the apache error log.
The apache Error log says

Thu Feb 17 14:38:11 2005] [error] [client 144.215.136.118] Can't locate vars.pm in @INC (@INC contains: .) at C:/apachefriends/xampp/htdocs/blosxom.cgi line 65.\r

at this line (inside of the bloxsom (perl file) there is the offending line that apache log is referring too)

use vars qw! $version $blog_title $blog_description $blog_language $datadir $url %template $template $depth $num_entries $file_extension $default_flavour $static_or_dynamic $plugin_dir $plugin_state_dir @plugins %plugins $static_dir $static_password @static_flavours $static_entries $path_info $path_info_yr $path_info_mo $path_info_da $path_info_mo_num $flavour $static_or_dynamic %month2num @num2month $interpolate $entries $output $header $show_future_entries %files %indexes %others !;

I presume this could? mean that one or more perl modules that blosxom needs isnt around.

I have used this same exact same file on an old linux distribution (with differing htdocs for the htdocs directory path, of course) without 'incident'...

If I figure this out I will post solution back to the group.

cheers again & thanks. gregh
TIA GregH
gregInHuntingtonBeachCA
 
Posts: 4
Joined: 17. February 2005 22:49

Postby Wiedmann » 18. February 2005 00:41

You should install the XAMPP Perl AddOn.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

ok -- I will try the perl add on & report...

Postby gregInHuntingtonBeachCA » 18. February 2005 16:10

Good suggestion... I did not know of any addons...
I will try to see if this add on helps & will report my findings.

cheers & thanks gregh
TIA GregH
gregInHuntingtonBeachCA
 
Posts: 4
Joined: 17. February 2005 22:49

ANSWER! -- basically, since XAM perl 5.8 it will never work

Postby gregInHuntingtonBeachCA » 18. February 2005 16:55

ANSWER! -- basically, since yo have perl 5.8 it will never work.


It turns out the the 'use xxx' construct in perl 5.8 has been depricated to something called 'our'. replacing all perl 'use xxx' constructs with the perl 'our' construct caused all sorts of other problems, that I do not have the time to debug (maybe later).

So to get this to work I just installed the windows version of active perl 5.6.1 into a different directory & altered the starting #!/path to the 5.6.12 perl.exe in the Blosxom script.

This is too bad that this wont work with newer perl releases... I think the Blosxom blog would be an excellent item to add to the XAMPP bundle if a new version comes out &/or it couldbe tweaked to work.

Cheers & regards, GregH
TIA GregH
gregInHuntingtonBeachCA
 
Posts: 4
Joined: 17. February 2005 22:49


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 33 guests