Xampp with Content Management System

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Xampp with Content Management System

Postby ScriptHam » 14. February 2005 14:55

I am a newbie and a little confused. :?:

I hope to install and run phpwcms on my Windows XP Pro c: HDD. This would be a test setup to get experience of the system. If this runs well I would then try the same on an intranet. At the moment I have xampplite giving me php 5, apache and mysql and mysqladmin.

Q1) If I download Freetype, ImageMagick and Ghostscript; where do I put them?

Q2) Where do I unzip the content management system files?
I will probably use phpwcms for the content management system.

Q3) Are there special configuration issues?

I have posted a similar question on the phpwcms forum and was directed to apachefriends.

I look forward to hearing how best to procede.
Thankyou very much.
:?: ScriptHam
ScriptHam
 
Posts: 10
Joined: 06. February 2005 01:03

Postby Wiedmann » 14. February 2005 15:13

Q1) ask phpwcms (did they use binarys or PHP extensions for this functions?)
BTW: Freetype is part of the PHP GD2 extension. There is an ImageMagick PHP extension inside XAMPP.

Q2) \xampp\htdocs --> readme_en.txt

Q3) ask phpwcms (enable the ImageMagick PHP extension in the php.ini)
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby ScriptHam » 14. February 2005 18:47

Thanks Wiedmann you have helped me very much. I have asked phpwcms also and they have helped.

I think that I know what to do now and if time permits I will try this tonight.

Many thanks :D
ScriptHam
ScriptHam
 
Posts: 10
Joined: 06. February 2005 01:03

Postby sckoh » 21. May 2005 03:03

Well, I am under same question.
At WinXP/xampplite, I unquoted extension=php_imagick.dll, extension_dir = "E:\xampp\php\ext\" of apache/bin/php.ini.

and got a message saying that
Code: Select all
1. CORE_RL_magick_.dll cannot be found.
2. php_imagik.dll cannot be found, even though it is at php/ext folder.


How cani I fix this?

Thank you.
Image
User avatar
sckoh
 
Posts: 67
Joined: 01. March 2005 02:16
Location: Washington DC


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 50 guests