xampp install seems ok but connecting to apache isn't

Problems with the Windows version of XAMPP, questions, comments, and anything related.

xampp install seems ok but connecting to apache isn't

Postby davedenis » 08. February 2005 22:02

I have tried running the apache_start.bat and get regular output:

Diese Eingabeforderung nicht waehrend des Running beenden
Bitte erst bei einem gewollten Shutdown schliessen
Please close this command only for Shutdown
Apache 2 is starting ...

but when I go to http://localhost/ I get "waiting for localhost" and then nothing. I'm running WinXP home SP2 and have tried another WAMP install called phpdev and that seems to work so I'm not sure what is wrong with the install. I've checked the FAQ but nothing is there for this. Any thoughts??
davedenis
 
Posts: 4
Joined: 08. February 2005 21:49

Postby davedenis » 09. February 2005 04:58

just to add a bit off info, I checked the error logs and this shows up hundreds of times:

[Tue Feb 08 22:11:19 2005] [error] (OS 10038)An operation was attempted on something that is not a socket. : Child 4408: Encountered too many errors accepting client connections. Possible causes: dynamic address renewal, or incompatible VPN or firewall software. Try using the Win32DisableAcceptEx directive.

now, previously I mentioned that another WAMP package works but I realized that one includes apache 1.3.27 whereas XAMPP uses apache 2. I do have SP2 but I have disabled the firewall. I also have McAfee but I have tried disabling that. I am convinced the problem is with port blocking somewhere but not sure why since both versions of apache access 80. Maybe this additional info helps, any ideas?
davedenis
 
Posts: 4
Joined: 08. February 2005 21:49

Postby Wiedmann » 09. February 2005 05:04

Try using the Win32DisableAcceptEx directive.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby davedenis » 09. February 2005 21:19

Wiedmann wrote:
Try using the Win32DisableAcceptEx directive.


After looking this, I added "Win32DisableAcceptEx" to my httpd.conf on it's own line anf BINGO I'm in business. Thanks!
davedenis
 
Posts: 4
Joined: 08. February 2005 21:49


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 33 guests