Page 1 of 1

wrong charset

PostPosted: 05. February 2005 00:18
by smoky
How do i change the charset UTF-8 Unicode (utf8) into English en-iso-8859-1

When I export an sql file it looks like this

ENGINE=MyISAM DEFAULT CHARSET=utf8 COLLATE=utf8_bin COMMENT='Column privileges';

When i export from myphpadmin from my webhost it looks like this:


Can somebody please tell me how to change the charset and how to disable the charset and the collate tags in the sql file ?

I get syntax errors when i try to upload to my webhost

PostPosted: 05. February 2005 11:46
by Wiedmann
You must use the console utility mysqldump.exe.

PostPosted: 05. February 2005 12:47
by smoky
Thanks I'll try that. The big problem for me is that those manuals are written for rocket scientist. Most of the times I need a clearer step by step explenation :(

I'm sorry for being such a newbie.. but what exactly do i put in the shell box ?
>mysqldump ...... ....... ?

I also have another problem trying, error 1044 access denied for user..
xamp was very easy to install but to configure it's a whole different cup a tea..

Please help.. I did not have any problems with previous version of xamp

PostPosted: 05. February 2005 13:23
by Wiedmann
Code: Select all
mysqldump.exe --compatible=mysql40 --default-character-set=latin1 --user=root --password db_name > backup.sql

PostPosted: 05. February 2005 13:28
by smoky
thanks alot !!!

Will try it immediately

Thank you so much.. it seemed to work :) :) :) :) :)

PostPosted: 05. February 2005 13:47
by smoky
when i upload the sql file to my webhost i still get a syntax error :(

MySQL said:
#1064 - You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 'DEFAULT CHARSET=utf8' at line 25

In myphpadmin it also still shows:

Language:English (en-utf8)
MySQL charset: UTF-8 Unicode (utf8)

*pulls hairs for upgrading xampplite*

PostPosted: 05. February 2005 18:47
by smoky
how do i turn off collate and charset in my SQL exports ?

PostPosted: 06. February 2005 14:40
by smoky
I downloaded 1.4.9 again.. problem solved..
I didn't know it was still up there for download..

Thanks anyway