wrong charset

Problems with the Windows version of XAMPP, questions, comments, and anything related.

wrong charset

Postby smoky » 05. February 2005 00:18

How do i change the charset UTF-8 Unicode (utf8) into English en-iso-8859-1

When I export an sql file it looks like this

ENGINE=MyISAM DEFAULT CHARSET=utf8 COLLATE=utf8_bin COMMENT='Column privileges';

When i export from myphpadmin from my webhost it looks like this:

TYPE=MyISAM AUTO_INCREMENT=1 ;

Can somebody please tell me how to change the charset and how to disable the charset and the collate tags in the sql file ?

I get syntax errors when i try to upload to my webhost
smoky
 
Posts: 7
Joined: 04. February 2005 22:50

Postby Wiedmann » 05. February 2005 11:46

You must use the console utility mysqldump.exe.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby smoky » 05. February 2005 12:47

Thanks I'll try that. The big problem for me is that those manuals are written for rocket scientist. Most of the times I need a clearer step by step explenation :(

I'm sorry for being such a newbie.. but what exactly do i put in the shell box ?
>mysqldump ...... ....... ?

I also have another problem trying, error 1044 access denied for user..
xamp was very easy to install but to configure it's a whole different cup a tea..

Please help.. I did not have any problems with previous version of xamp
smoky
 
Posts: 7
Joined: 04. February 2005 22:50

Postby Wiedmann » 05. February 2005 13:23

Code: Select all
mysqldump.exe --compatible=mysql40 --default-character-set=latin1 --user=root --password db_name > backup.sql
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby smoky » 05. February 2005 13:28

thanks alot !!!

Will try it immediately

Thank you so much.. it seemed to work :) :) :) :) :)
smoky
 
Posts: 7
Joined: 04. February 2005 22:50

Postby smoky » 05. February 2005 13:47

:(
when i upload the sql file to my webhost i still get a syntax error :(

MySQL said:
#1064 - You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 'DEFAULT CHARSET=utf8' at line 25

In myphpadmin it also still shows:

Language:English (en-utf8)
MySQL charset: UTF-8 Unicode (utf8)

*pulls hairs for upgrading xampplite*
smoky
 
Posts: 7
Joined: 04. February 2005 22:50

Postby smoky » 05. February 2005 18:47

how do i turn off collate and charset in my SQL exports ?
smoky
 
Posts: 7
Joined: 04. February 2005 22:50

Postby smoky » 06. February 2005 14:40

I downloaded 1.4.9 again.. problem solved..
I didn't know it was still up there for download..

Thanks anyway
smoky
 
Posts: 7
Joined: 04. February 2005 22:50


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 44 guests