Need to run Apache and IIS on same machine

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Need to run Apache and IIS on same machine

Postby jtsquared » 03. February 2005 22:27

We have a Windows 2000 web server running IIS. I just converted our old web site to run on Xampp, but it is running on a different machine. I would like to have our Windows 2000 box run IIS and Apache at the same time. However, I want Apache to serve web pages on port 81 (or a different open port) while IIS serves our InTRAnet on port 80. Can anyone tell me if this is possible and what I might have to do to make it work? The reason for this is that our Intranet is written in ASP and I'm not technical enough to run ASP on Apache.

Thanks!
jtsquared
 
Posts: 10
Joined: 11. October 2004 16:13
Location: TN

Postby Wiedmann » 03. February 2005 22:29

Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Both on Port 80

Postby jtsquared » 04. February 2005 15:59

Could they both (IIS and Apache) serve web pages on port 80 at the same time? I just figured the answer was no, but maybe I'm wrong...
jtsquared
 
Posts: 10
Joined: 11. October 2004 16:13
Location: TN

Postby Wiedmann » 04. February 2005 16:18

Could they both (IIS and Apache) serve web pages on port 80 at the same time?

No.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Can't start Apache as a service

Postby jtsquared » 04. February 2005 17:34

OK, I've got Xampp installed and configured Apache to listen on port 81. If I type: http://localhost:81, I get the Xampp page and IIS is still running fine. However, I want to install Apache as a service (since I'm running on a Win2K box) and when I try to do that, I get the error message:

(OS 10048) Only one usage of each socket address (protocol/network address/port) is normally permitted. : make_sock: could not bind to address 0.0.0.0:443 no listening sockets available, shutting down

(I suppose because IIS is using port 443). How do I prevent Apache from trying to bind to port 443 and let it run as a service?

Thanks![/img]
jtsquared
 
Posts: 10
Joined: 11. October 2004 16:13
Location: TN

Postby Wiedmann » 04. February 2005 17:39

The same like before... only the file is an other --> ssl.conf

(or, do not include the "ssl.conf" in "httpd.conf")
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany


Return to XAMPP for Windows

Who is online

Users browsing this forum: Altrea and 76 guests