XAMPP perl has mysteriously stopped working

Problems with the Windows version of XAMPP, questions, comments, and anything related.

XAMPP perl has mysteriously stopped working

Postby xaphod » 10. July 2018 21:43

so XAMPP is installed and working fine for a couple of months along with a smattering of Perl. Nothing changes, the perl runs fine, Apache runs fine. Then one day I get the Error 500 message on a perl script. It's annoying the hell out of me but before I can start looking to fix, it starts working again. A month or so later, same problem. Only it's permanent Error 500. I'm flummoxed. Throwing a clean install of XAMPP on the system throws up the same result. Trolling the Event Viewer I come across this:

Faulting application name: perl.exe, version: 0.0.0.0, time stamp: 0x513f2742
Faulting module name: perl516.dll, version: 0.0.0.0, time stamp: 0x513f2741
Exception code: 0xc0000005
Fault offset: 0x0011e7e5
Faulting process ID: 0x1a68
Faulting application start time: 0x01d41889c30be427
Faulting application path: C:\usr\xaphod0\iDev\_xampp\perl\bin\perl.exe
Faulting module path: C:\usr\xaphod0\iDev\_xampp\perl\bin\perl516.dll
Report ID: aa938569-ed5d-4493-907c-8ebfcf081ab8
Faulting package full name:
Faulting package-relative application ID:


So... Any here present care to take a stab in the dark and suggest a fix?
User avatar
xaphod
 
Posts: 2
Joined: 10. July 2018 21:18
XAMPP version: 7.2.7
Operating System: Windows 10

Re: XAMPP perl has mysteriously stopped working

Postby xaphod » 11. July 2018 09:57

:roll: okay, I swear I did nothing.
nothing you hear, nothing.

I did reboot for an upgrade last night just after posting, and this morning my perl works.

(and yes, I'd already tried rebooting my machine)

how odd.
User avatar
xaphod
 
Posts: 2
Joined: 10. July 2018 21:18
XAMPP version: 7.2.7
Operating System: Windows 10


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 36 guests