Webmin nicht mehr erreichbar seit Update

Seit kurzem gibt es Webmin als erstes experimentelles Add-on zu LAMPP. Hier geht es um die Erfahrungen mit diesem Zusatzmodul oder aber auch generell um Webmin.

Webmin nicht mehr erreichbar seit Update

Postby format » 22. February 2006 12:19

Hallo,


vor ein paar Tagen habe ich meinen XAMPP auf Debian 3.1. von 1.4.14 auf 1.4.16 geupdatet.

Seit dem ist Webmin, welches auf meiner Maschine separat installiert ist (also kein XAMPP-Addon) nicht mehr erreichbar (https://xxx.xxx.xxx.xxx:10000).

SSL ist aktiv, Ports habe ich auch nicht beschränkt und an der Webmin.conf wurde auch nix geändert.

Webmin wurde seinerzeit auch nicht als Paket installier, ergo auch nicht durch Debian Update zerschossen.

Für Hinweise dankbar ...


Grüße, olli
User avatar
format
 
Posts: 45
Joined: 11. September 2004 18:52
Location: Düsseldorf

Postby deepsurfer » 22. February 2006 12:44

Sollte nix mit XAMPP zutun haben, der Webmin ist rein Perl basierend und somit Apache (als Webserver) unabhängig, da er nur auf die PERL bibliotheken zugreift.
Und ich denke nicht das du alle Webmin scripte den Perlpfad zu XAMPP gelegt hattest.

Ich mein der Webmin wäre auch unter http://xxx.xxx.xxx.xxx:10000 zu erreichen.

Kann es sein das du im Debian entwas "DeInstalliert" hast
entweder über den PaketAssistenten in einer GUI oder mittels
"apt-get remove " ??
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
XAMPP Version: 5.6.3
Operating System: Win-XP / Win7 / Linux -Debian

Postby format » 22. February 2006 12:51

deepsurfer wrote:
Kann es sein das du im Debian entwas "DeInstalliert" hast
entweder über den PaketAssistenten in einer GUI oder mittels
"apt-get remove " ??


nope :-(
User avatar
format
 
Posts: 45
Joined: 11. September 2004 18:52
Location: Düsseldorf

Postby format » 01. March 2006 13:29

Hallo zusammen,


stehe leider noch immer vor diesem Problem. Webmin ist installiert und imho auch richtig konfiguriert. Vor dem Xampp Update funktionierte es. Außer dem Update wurde an der Maschine nichts weiter verändert.

/usr/local/webmin# ./setup.sh
***********************************************************************
* Welcome to the Webmin setup script, version 1.260 *
***********************************************************************
Webmin is a web-based interface that allows Unix-like operating
systems and common Unix services to be easily administered.

Installing Webmin in /usr/local/webmin ...

***********************************************************************
Webmin uses separate directories for configuration files and log files.
Unless you want to run multiple versions of Webmin at the same time
you can just accept the defaults.

Config file directory [/etc/webmin]:
Found existing Webmin configuration in /etc/webmin


cat: /etc/webmin/var-path: No such file or directory
Inserting path to perl into scripts..
..done

Creating start and stop scripts..
..done

Updating config files..

..done

Creating uninstall script /etc/webmin/uninstall.sh ..
..done

Changing ownership and permissions ..
./setup.sh: line 741: [: !=: unary operator expected
..done

Running postinstall scripts ..
..done

***********************************************************************
Webmin has been installed and started successfully. Use your web
browser to go to

https://cls-crew.com:10000/

and login with the name and password you entered previously.

Because Webmin uses SSL for encryption only, the certificate
it uses is not signed by one of the recognized CAs such as
Verisign. When you first connect to the Webmin server, your
browser will ask you if you want to accept the certificate
presented, as it does not recognize the CA. Say yes.

root@cls-crew:/usr/local/webmin#


Hat jemand eine Idee?

[edit]

Was mich gerade ein bisschen wundert ist, dass Webmin scheinbar gar nicht läuft.
ps -aux
Warning: bad syntax, perhaps a bogus '-'? See http://procps.sf.net/faq.html
USER PID %CPU %MEM VSZ RSS TTY STAT START TIME COMMAND
root 1 0.0 0.0 1516 536 ? S Feb22 0:02 init [2]
root 2 0.0 0.0 0 0 ? SN Feb22 0:00 [ksoftirqd/0]
root 3 0.0 0.0 0 0 ? S< Feb22 0:06 [events/0]
root 4 0.0 0.0 0 0 ? S< Feb22 0:00 [khelper]
root 22 0.0 0.0 0 0 ? S< Feb22 0:00 [kacpid]
root 109 0.0 0.0 0 0 ? S< Feb22 0:00 [kblockd/0]
root 148 0.0 0.0 0 0 ? S Feb22 0:00 [pdflush]
root 150 0.0 0.0 0 0 ? S< Feb22 0:00 [aio/0]
root 149 0.0 0.0 0 0 ? S Feb22 0:02 [kswapd0]
root 737 0.0 0.0 0 0 ? S Feb22 0:00 [kseriod]
root 871 0.0 0.0 0 0 ? S< Feb22 0:00 [ata/0]
root 1060 0.0 0.0 0 0 ? S Feb22 0:07 [kjournald]
root 1384 0.0 0.0 0 0 ? S Feb22 0:00 [kjournald]
root 1385 0.0 0.0 0 0 ? S Feb22 0:01 [kjournald]
root 1386 0.0 0.0 0 0 ? S Feb22 0:00 [kjournald]
root 1748 0.0 0.0 0 0 ? S Feb22 0:00 [khubd]
root 2339 0.0 0.0 0 0 ? S Feb22 0:00 [shpchpd_event]
root 3295 0.0 0.0 2396 896 ? Ss Feb22 0:00 dhclient -e -pf /var/run/dhclient.eth0.pid -lf /var/run/dhclient.eth0.leases eth0
root 3682 0.0 0.0 2280 824 ? Ss Feb22 0:01 /sbin/syslogd
root 3685 0.0 0.1 2384 1500 ? Ss Feb22 0:00 /sbin/klogd
cyrus 3720 0.0 0.2 5200 2252 ? Ss Feb22 0:00 /usr/sbin/cyrmaster -d
cyrus 3790 0.0 0.1 3948 1092 ? S Feb22 0:00 notifyd
Debian- 3855 0.0 0.3 9196 2772 ? Ss Feb22 0:00 /usr/sbin/exim4 -bd -q30m
nobody 3867 0.0 0.1 2452 928 ? Ss Feb22 0:00 /usr/sbin/oidentd -mf -P 213.239.217.65 -u nobody -g nogroup
root 3877 0.0 0.1 3540 1604 ? Ss Feb22 0:00 /usr/sbin/sshd
root 3885 0.0 0.1 2924 1084 ? Ss Feb22 0:00 /usr/sbin/xinetd -pidfile /var/run/xinetd.pid -stayalive
root 3890 0.0 0.4 3996 3996 ? SLs Feb22 0:07 /usr/sbin/ntpd -p /var/run/ntpd.pid
root 3895 0.0 0.0 1812 896 ? Ss Feb22 0:00 /usr/sbin/cron
tss 3951 0.1 0.3 112356 2840 ? SN Feb22 15:08 /home/tss/tss2_cls/server_linux -pid=/home/tss/tss2_cls/tss.pid -db=/home/tss/tss2_cls/server.
root 4063 0.0 0.0 1512 500 tty1 Ss+ Feb22 0:00 /sbin/getty 38400 tty1
root 4064 0.0 0.0 1512 500 tty2 Ss+ Feb22 0:00 /sbin/getty 38400 tty2
root 4065 0.0 0.0 1512 500 tty3 Ss+ Feb22 0:00 /sbin/getty 38400 tty3
root 4066 0.0 0.0 1512 500 tty4 Ss+ Feb22 0:00 /sbin/getty 38400 tty4
root 4067 0.0 0.0 1512 500 tty5 Ss+ Feb22 0:00 /sbin/getty 38400 tty5
root 4068 0.0 0.0 1512 500 tty6 Ss+ Feb22 0:00 /sbin/getty 38400 tty6
irc 4219 0.0 0.2 3656 2452 ? S Feb22 2:38 ./psybnc
sku 4220 0.0 0.3 12920 3060 ? S Feb22 0:02 /home/sku/eggdrop/eggdrop ./cls-crew.conf
spearhe 4512 0.0 0.1 2728 1260 ? S Feb22 0:00 /bin/sh ./start_spearhead.sh
spearhe 4513 0.7 16.8 158684 152840 ? S Feb22 75:26 /home/spearhead/mohaa/spearhead_lnxded +set dedicated 1 +set logfile 3 +set g_logsync 1 +set n
root 18430 0.0 0.0 0 0 ? S Feb27 0:00 [pdflush]
root 32577 0.0 0.2 14532 2244 ? Ss 12:50 0:00 sshd: obe [priv]
obe 32580 0.0 0.2 14700 2332 ? S 12:50 0:00 sshd: obe@pts/1
obe 32581 0.0 0.2 3564 1928 pts/1 Ss 12:50 0:00 -bash
shrifle 32682 0.0 0.1 2728 1260 pts/1 S 13:02 0:00 /bin/sh ./start_shrifle.sh +exec clsfreeze.cfg
shrifle 32683 0.2 9.0 88264 82260 pts/1 S 13:02 0:05 /home/shrifle/mohaa/spearhead_lnxded +set dedicated 1 +set logfile 3 +set g_logsync 1 +set net
root 32763 0.0 0.1 3040 1724 pts/1 S 13:05 0:00 bash
root 618 0.0 1.3 20888 12348 ? Ss 13:18 0:00 /opt/lampp/bin/httpd -k start -DSSL -DPHP4
root 635 0.0 0.1 2760 1352 pts/1 S 13:18 0:00 /bin/sh /opt/lampp/bin/mysqld_safe --datadir=/opt/lampp/var/mysql --pid-file=/opt/lampp/var/my
nobody 662 0.1 0.8 29308 7624 pts/1 S 13:18 0:01 /opt/lampp/sbin/mysqld --basedir=/opt/lampp --datadir=/opt/lampp/var/mysql --user=nobody --pid
identd 664 0.0 0.2 6224 2664 ? Ss 13:18 0:00 proftpd: (accepting connections)
nobody 676 0.0 1.8 25356 17068 ? S 13:18 0:00 /opt/lampp/bin/httpd -k start -DSSL -DPHP4
nobody 677 0.0 1.8 25044 16732 ? S 13:18 0:00 /opt/lampp/bin/httpd -k start -DSSL -DPHP4
nobody 678 0.0 1.8 25356 17036 ? S 13:18 0:00 /opt/lampp/bin/httpd -k start -DSSL -DPHP4
nobody 764 0.1 1.7 24344 16084 ? S 13:22 0:00 /opt/lampp/bin/httpd -k start -DSSL -DPHP4
nobody 767 0.0 1.9 25504 17272 ? S 13:22 0:00 /opt/lampp/bin/httpd -k start -DSSL -DPHP4
nobody 768 0.0 1.8 25324 17064 ? S 13:22 0:00 /opt/lampp/bin/httpd -k start -DSSL -DPHP4
nobody 835 0.0 1.6 23708 15336 ? S 13:25 0:00 /opt/lampp/bin/httpd -k start -DSSL -DPHP4
nobody 954 0.0 1.8 25116 16856 ? S 13:27 0:00 /opt/lampp/bin/httpd -k start -DSSL -DPHP4
nobody 986 0.0 1.8 24980 16656 ? S 13:29 0:00 /opt/lampp/bin/httpd -k start -DSSL -DPHP4
nobody 1059 0.0 1.3 21020 12460 ? S 13:33 0:00 /opt/lampp/bin/httpd -k start -DSSL -DPHP4
root 1075 0.0 0.2 8488 2512 ? S 13:35 0:00 /usr/sbin/exim4 -q
root 1103 0.0 0.3 8508 3020 ? S 13:35 0:00 /usr/sbin/exim4 -q
Debian- 1104 0.0 0.3 9220 3260 ? S 13:35 0:00 /usr/sbin/exim4 -q
root 1108 0.0 0.0 2536 884 pts/1 R+ 13:35 0:00 ps -aux


Starten mit "/usr/local/webmin/miniserv.pl /etc/webmin/miniserv.conf" bringt auch keine Veränderung :-(

Danke & Gruß, ol*binzuplöt*li
User avatar
format
 
Posts: 45
Joined: 11. September 2004 18:52
Location: Düsseldorf

Postby dragon4 » 28. June 2006 11:05

hi,

bei mir started der mit "/etc/init.d/webmin start"
und da steht
DAEMON=/usr/share/webmin/miniserv.pl

kann latürnich von distri zu distri unterschiedlich sein
ich hab gerade mal auf einer debian auf sun nachgeschaut

gruß, dragon4
dragon4
 
Posts: 1
Joined: 28. June 2006 10:55

Postby deepsurfer » 29. June 2006 13:00

Also auf der gennanten Domain erhalte ich den Webmin zugang....
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
XAMPP Version: 5.6.3
Operating System: Win-XP / Win7 / Linux -Debian


Return to Webmin

Who is online

Users browsing this forum: No registered users and 1 guest

cron