phpmyadmin versionen inkompatibel?

Und alles was mit phpMyAdmin seine Verwandtschaft findet hat hier seinen Platz.

phpmyadmin versionen inkompatibel?

Postby xampp_rookie » 20. January 2005 22:06

hi!

stehe kurz vor einem provider-umzug und wollte sämtliche daten meiner datenbank auf meinen lokalen rechner überspielen. ein backup zu erzeugen und lokal einzuspielen hat bislang immer geklappt.

ich habe mir nun die aktuellste xampp version gezogen, da sie die selbe phpmyadmin-version enthält, wie auch mein künftiger provider.

das problem ist nun, dass der text in meinen php-scripts nur verstümmelt angezeigt wird, d.h. sobald ein umlaut im text vorkommt wird der rest einfach abgeschnitten und nicht angezeigt.

aus: "verstümmelt" wird also "verst

der text ist BTW auch innerhalb der tabellen verstümmelt.

woran kann das liegen? falscher zeichensatz? wie lässt sich das beheben?

phpmyadmin-version am derzeitigen webserver: 2.5.7-pl1 (MySQL 4.0.14)
phpmyadmin-version lokal: 2.6.0-pl3 (MySQL 4.1.8-nt)

habe nun testhalber auch versucht das backup mit einem anderen tool zu erstellen (mysqldumper), das ergebnis ist jedoch das selbe :(

bitte um hilfe!
xampp_rookie
 
Posts: 15
Joined: 20. January 2005 21:54

Postby xampp_rookie » 20. January 2005 22:27

das dump-file mit textpad zu öffnen und im UNIX format mit UTF-8 zeichensatz zu speichern in lokal mit phpmyadmin 2.6.0 wieder einzuspielen funktioniert übrigens auch nicht :(

"Après-Ski" wird beispielsweise so dargestellt: "Après-Ski"
xampp_rookie
 
Posts: 15
Joined: 20. January 2005 21:54

Postby xampp_rookie » 22. January 2005 11:30

das einlesen in die datenbank funktioniert jetzt. sämtliche umlaute sind korrekt vorhanden. sobald ich einen datensatz aus der datenbank hole und mit php auszugeben versuche erhalte ich für äüö folgende ausgabe äüö (datensatz wurde mit phpmyadmin utf8-codiert eingegeben). das ganze ist also ein reines darstellungsproblem, das ich unter MySQL 4.0.14 nicht hatte unter version 4.1.8-nt dagegen sehr wohl.

wie lässt sich das beheben? bitte nochmals um hilfestellung!
xampp_rookie
 
Posts: 15
Joined: 20. January 2005 21:54

Postby xampp_rookie » 23. January 2005 09:35

xampp_rookie
 
Posts: 15
Joined: 20. January 2005 21:54


Return to phpMyAdmin

Who is online

Users browsing this forum: No registered users and 6 guests