Access denied for user: 'root@localhost' (Using password: NO

Und alles was mit phpMyAdmin seine Verwandtschaft findet hat hier seinen Platz.

Access denied for user: 'root@localhost' (Using password: NO

Postby Sarah19 » 19. September 2004 17:18

Kann mir jmd mit dem Problem helfen? Immer wenn ich im Xampp Fenster auf PHPMyAdmin klicke erscheint diese Fehlermeldung. Weiß nicht mehr weiter *heul*

Danke schonmal im vorraus
User avatar
Sarah19
 
Posts: 58
Joined: 23. August 2004 17:09

Postby Wiedmann » 19. September 2004 17:31

Hast du für den Benutzer "root" in MySQL ein Passwort vergeben?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby Sarah19 » 19. September 2004 19:23

ja habe ich
User avatar
Sarah19
 
Posts: 58
Joined: 23. August 2004 17:09

Postby Wiedmann » 19. September 2004 19:39

Im Verzeichnis "\xampp\phpmyadmin\" gibt es die Datei "config.inc.php".

In dieser Datei gibt es die zwei Zeilen:
Code: Select all
$cfg['Servers'][$i]['user']          = 'root';          // MySQL user
$cfg['Servers'][$i]['password']      = '';              // MySQL password (only needed


Bei "$cfg['Servers'][$i]['password']" mußt du das entsprechende Passwort eintragen.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby Sarah19 » 19. September 2004 22:03

Danke, hatte das schonmal gemacht, nur hab es bis jetzt schonwieder vergessen gehabt.

Echt klasse die schnelle Hilfe, tausend dank nochmal
User avatar
Sarah19
 
Posts: 58
Joined: 23. August 2004 17:09

Postby Kristian Marcroft » 23. September 2004 07:46

Hi,

solltest evtl. wenn dein Apache am Internet hängt noch folgendes beherzigen:
http://apf.kwm-web.info/downloads/lampp ... -howto.pdf

So long
KriS
User avatar
Kristian Marcroft
AF Moderator
 
Posts: 2962
Joined: 03. January 2003 12:08
Location: Diedorf

Postby ImZ » 24. September 2004 09:53

Hi!

Das problem hatte ich auch *gg* und zwar so, dass ich mich durch Vergabe des Passwortes so ausgesperrt hatte.
Die Änderungen an der Datei config.inc.php habens gelöst :-)

Nur sollte man sich vorher eine Sicherheitskopie anfertigen und darauf achten, was man wo ändert!

Die genannten Zeilen kommen in der Datei mehrfach in anderem Kontext vor, ändert man die falsche Zeile führt das nicht zu dem gewünschten Ergebnis! Pauschal die erste Möglichkeit 'von oben' nehmen geht in diesem speziellen Fall ;-)

ImZ
ImZ
 
Posts: 1
Joined: 24. September 2004 07:31


Return to phpMyAdmin

Who is online

Users browsing this forum: No registered users and 1 guest