Das $cfg['PmaAbsoluteUri']-Verzeichnis MUSS

Und alles was mit phpMyAdmin seine Verwandtschaft findet hat hier seinen Platz.

Das $cfg['PmaAbsoluteUri']-Verzeichnis MUSS

Postby Miang » 06. March 2004 11:09

Das $cfg['PmaAbsoluteUri']-Verzeichnis MUSS in Ihrer Konfigurationsdatei angegeben werden!

Ihre Konfigurationsdatei enthält Einstellungen (Benutzer "root" ohne Passwort), welche denen des MySQL-Standardbenutzers entsprechen. Wird Ihr MySQL-Server mit diesen Einstellungen betrieben, so können Unbefugte leicht von außen auf ihn zugreifen. Sie sollten diese Sicherheitslücke unbedingt schließen!

kann mir da einer weiterhelfen was genau ich da machen muss ?

Danke
Bin Anfänger
deshalb bitte nicht so grob !!!
www.i-scripts.de
User avatar
Miang
 
Posts: 22
Joined: 15. February 2004 13:43
Location: Bad Vilbel

Postby Kristian Marcroft » 06. March 2004 14:27

Hi,

steht alles in der FAQ:

http://faq.kwm-web.info/index.php?sid=1 ... 11&lang=de

So long
KriS
User avatar
Kristian Marcroft
AF Moderator
 
Posts: 2962
Joined: 03. January 2003 12:08
Location: Diedorf

Postby SteGra » 12. April 2004 13:34

Habe es wie in den Faq beschrieben geändert, bekomme aber jetzt beim aufrufen von PhpMyAdmin folgende Meldung

Ab sofort muss ein geheimes Passwort zur Verschlüsselung in der Konfigurationsdatei gesetzt werden (blowfish_secret).



Was muss ich jetzt noch einstellen?
SteGra
 
Posts: 48
Joined: 26. December 2003 16:05

Postby Kristian Marcroft » 12. April 2004 13:35

Hi,

ein bisschen suchen is nicht zu viel verlangt:
http://www.apachefriends.org/faq-lampp.html#blowfish

So long
KriS
User avatar
Kristian Marcroft
AF Moderator
 
Posts: 2962
Joined: 03. January 2003 12:08
Location: Diedorf

Postby SteGra » 12. April 2004 13:42

Sorry, dass ich nicht gesucht habe und danke für deine Hilfe!!!

Jetzt kommt leider immer "Objekt nicht gefunden" (also 404). Wenn du da auch noch einen Tip für mich hast wäre das sehr gut! Weiß leider nicht wonach ich suchen soll.
SteGra
 
Posts: 48
Joined: 26. December 2003 16:05

Postby Kristian Marcroft » 12. April 2004 13:44

Hi,

wo kommt das?
Wann kommt das?

Was sagt dein apache error_log dazu?

So long
KriS
User avatar
Kristian Marcroft
AF Moderator
 
Posts: 2962
Joined: 03. January 2003 12:08
Location: Diedorf

Postby SteGra » 12. April 2004 13:51

Das kommt nach der Benutzeranmeldung aus dem Internet.

Der Fehler im Log sieht so aus:

script not found or unable to stat
[Mon Apr 12 02:19:43 2004] [error] [client 24.92.72.75] File does not exist: C:/Dokumente und Einstellungen/Packard bell.BARBARA/Desktop/xampp/htdocs/tld

[Mon Apr 12 12:35:47 2004] [error] [client 213.23.164.238] File does not exist: C:/Dokumente und Einstellungen/Packard bell.BARBARA/Desktop/xampp/htdocs/Stufe12/phpmyadmin, referer: http://www.stufe12.de.ms/phpmyadmin

[Mon Apr 12 12:35:55 2004] [error] [client 213.23.164.238] File does not exist: C:/Dokumente und Einstellungen/Packard bell.BARBARA/Desktop/xampp/htdocs/Stufe12/phpmyadmin, referer: http://stegra.homeip.net/phpmyadmin/

[Mon Apr 12 12:36:03 2004] [error] [client 213.23.164.238] File does not exist: C:/Dokumente und Einstellungen/Packard bell.BARBARA/Desktop/xampp/htdocs/Stufe12/phpmyadmin, referer: http://stegra.homeip.net/phpmyadmin/

[Mon Apr 12 12:36:05 2004] [error] [client 213.23.164.238] File does not exist: C:/Dokumente und Einstellungen/Packard bell.BARBARA/Desktop/xampp/htdocs/Stufe12/phpmyadmin, referer: http://stegra.homeip.net/phpmyadmin/

[Mon Apr 12 12:43:19 2004] [error] [client 213.23.164.238] File does not exist: C:/Dokumente und Einstellungen/Packard bell.BARBARA/Desktop/xampp/htdocs/Stufe12/phpmyadmin, referer: http://stegra.homeip.net/phpmyadmin/

[Mon Apr 12 12:43:24 2004] [error] [client 213.23.164.238] File does not exist: C:/Dokumente und Einstellungen/Packard bell.BARBARA/Desktop/xampp/htdocs/Stufe12/phpmyadmin, referer: http://stegra.homeip.net/phpmyadmin/

[Mon Apr 12 12:43:30 2004] [error] [client 213.23.164.238] File does not exist: C:/Dokumente und Einstellungen/Packard bell.BARBARA/Desktop/xampp/htdocs/Stufe12/phpmyadmin, referer: http://stegra.homeip.net/phpmyadmin/

[Mon Apr 12 12:43:40 2004] [error] [client 213.23.164.238] File does not exist: C:/Dokumente und Einstellungen/Packard bell.BARBARA/Desktop/xampp/htdocs/Stufe12/phpmyadmin, referer: http://stegra.homeip.net/phpmyadmin/

[Mon Apr 12 12:43:41 2004] [error] [client 213.23.164.238] File does not exist: C:/Dokumente und Einstellungen/Packard bell.BARBARA/Desktop/xampp/htdocs/Stufe12/phpmyadmin, referer: http://stegra.homeip.net/phpmyadmin/


Sorry, falls ich nerve, habe aber nicht so die Mega-Erfahrung!
Scheinbar fehlen da ja die / am Ende der Pfade, aber wo soll ich die ergänzen? Bisher hats ja auch immer getan!
SteGra
 
Posts: 48
Joined: 26. December 2003 16:05

Postby Kristian Marcroft » 12. April 2004 13:54

Hi,

was hasten angegeben bei der:
$cfg['PmaAbsoluteUri'] ??

ggf. mal im Chat vorbei schaun und mir die config.inc.php zukommen lassen.

So long
KriS
User avatar
Kristian Marcroft
AF Moderator
 
Posts: 2962
Joined: 03. January 2003 12:08
Location: Diedorf

Postby SteGra » 12. April 2004 13:58

Die sieht bei mir so aus:

$cfg['PmaAbsoluteUri'] = 'http://stegra.homeip.net/Stufe12/phpmyadmin/'


Müsste eigentlich richtig sein! Werde dir aber zur Sicherheit die Datei mal per E-Mail senden.
SteGra
 
Posts: 48
Joined: 26. December 2003 16:05

Postby Kristian Marcroft » 12. April 2004 14:02

SteGra wrote:Die sieht bei mir so aus:

$cfg['PmaAbsoluteUri'] = 'http://stegra.homeip.net/Stufe12/phpmyadmin/'


Müsste eigentlich richtig sein! Werde dir aber zur Sicherheit die Datei mal per E-Mail senden.

Hi,

nimm mal das Stufe12 raus.

also:
$cfg['PmaAbsoluteUri'] = 'http://stegra.homeip.net/phpmyadmin/'

Und dann greifst auch drauf zu mit:
http://stegra.homeip.net/phpmyadmin/

So long
KriS
User avatar
Kristian Marcroft
AF Moderator
 
Posts: 2962
Joined: 03. January 2003 12:08
Location: Diedorf

Postby SteGra » 12. April 2004 14:18

Hey danke! Hätte ich eigentlich selber drauf kommen müssen!

Aber da ist schon wieder das nächste Problem.

Die Startseite von Phpmyadmin wird nicht geladen. Seite kann nicht angezeigt werden.Links die Tabellenauswahl ist aber da...
SteGra
 
Posts: 48
Joined: 26. December 2003 16:05

Postby Kristian Marcroft » 12. April 2004 14:20

Hi,

leere mal deinen BrowserCache....

Ansonsten bräucht ich wieder nen Log Auszug.

So long
KriS
User avatar
Kristian Marcroft
AF Moderator
 
Posts: 2962
Joined: 03. January 2003 12:08
Location: Diedorf

Postby SteGra » 12. April 2004 14:24

Wieder den Auszug aus den Apache-Logs?

Da steht nichts drin, zumindest keine aktuellen Fehler! Nur das von eben und die Fehler bei den zugriffen über deine IP! Das wars...
SteGra
 
Posts: 48
Joined: 26. December 2003 16:05

Postby Kristian Marcroft » 12. April 2004 14:28

Hi,

dann wären die Access Logs interessant :)

So long
KriS
User avatar
Kristian Marcroft
AF Moderator
 
Posts: 2962
Joined: 03. January 2003 12:08
Location: Diedorf

Postby SteGra » 12. April 2004 14:33

Das wären diese:


213.23.164.238 - - [12/Apr/2004:13:19:29 +0200] "GET /phpmyadmin/ HTTP/1.1" 200 6548

213.23.164.238 - - [12/Apr/2004:13:19:29 +0200] "GET /phpmyadmin/images/pma_logo.png HTTP/1.1" 200 1527

213.23.164.238 - - [12/Apr/2004:13:19:31 +0200] "POST /phpmyadmin/index.php HTTP/1.1" 200 6548

213.23.164.238 - - [12/Apr/2004:13:19:31 +0200] "POST /phpmyadmin/index.php HTTP/1.1" 200 6548

213.23.164.238 - - [12/Apr/2004:13:19:32 +0200] "POST /phpmyadmin/index.php HTTP/1.1" 302 -

213.23.164.238 - - [12/Apr/2004:13:19:33 +0200] "GET /phpmyadmin/index.php?lang=de-iso-8859-1&server=1
HTTP/1.1" 200 6686

213.23.164.238 - - [12/Apr/2004:13:19:39 +0200] "POST /phpmyadmin/index.php HTTP/1.1" 302 -

213.23.164.238 - - [12/Apr/2004:13:19:40 +0200] "GET /phpmyadmin/index.php?lang=de-iso-8859-1&server=1 HTTP/1.1" 200 2406

213.23.164.238 - - [12/Apr/2004:13:19:40 +0200] "GET /phpmyadmin/css/phpmyadmin.css.php?lang=de-iso-8859-1&js_frame=right HTTP/1.1" 200 6376

213.23.164.238 - - [12/Apr/2004:13:19:40 +0200] "GET /phpmyadmin/queryframe.php?lang=de-iso-8859-1&server=1&hash=0e6d67ccc9767d55bb88a49764e681f11081768780 HTTP/1.1" 200 2086

213.23.164.238 - - [12/Apr/2004:13:19:40 +0200] "GET /phpmyadmin/left.php?lang=de-iso-8859-1&server=1&hash=0e6d67ccc9767d55bb88a49764e681f11081768780 HTTP/1.1" 200 2397

213.23.164.238 - - [12/Apr/2004:13:19:41 +0200] "GET /phpmyadmin/css/phpmyadmin.css.php?lang=de-iso-8859-1&js_frame=left&num_dbs=0 HTTP/1.1" 200 940

213.23.164.238 - - [12/Apr/2004:13:19:41 +0200] "GET /phpmyadmin/css/phpmyadmin.css.php?js_frame=left&num_dbs=0 HTTP/1.1" 200 940

213.23.164.238 - - [12/Apr/2004:13:19:41 +0200] "GET /phpmyadmin/main.php?lang=de-iso-8859-1&server=1 HTTP/1.1" 200 14830

213.23.164.238 - - [12/Apr/2004:13:19:41 +0200] "GET /phpmyadmin/css/phpmyadmin.css.php?lang=de-iso-8859-1&js_frame=right HTTP/1.1" 200 6376

80.137.59.25 - - [12/Apr/2004:13:22:00 +0200] "GET /phpmyadmin/index.php HTTP/1.1" 200 6548

80.137.59.25 - - [12/Apr/2004:13:22:01 +0200] "GET /phpmyadmin/images/pma_logo.png HTTP/1.1" 200 1527

80.137.59.25 - - [12/Apr/2004:13:22:04 +0200] "POST /phpmyadmin/index.php HTTP/1.1" 302 -

80.137.59.25 - - [12/Apr/2004:13:22:04 +0200] "GET /phpmyadmin/index.php?lang=de-iso-8859-1&server=1
HTTP/1.1" 200 6690

80.137.59.25 - - [12/Apr/2004:13:22:14 +0200] "POST /phpmyadmin/index.php HTTP/1.1" 302 -

80.137.59.25 - - [12/Apr/2004:13:22:15 +0200] "GET /phpmyadmin/index.php?lang=de-iso-8859-1&server=1 HTTP/1.1" 200 6691

80.137.59.25 - - [12/Apr/2004:13:22:18 +0200] "POST /phpmyadmin/index.php HTTP/1.1" 302 -

80.137.59.25 - - [12/Apr/2004:13:22:18 +0200] "GET /phpmyadmin/index.php?lang=de-iso-8859-1&server=1 HTTP/1.1" 200 6691

80.137.59.25 - - [12/Apr/2004:13:24:23 +0200] "POST /phpmyadmin/index.php HTTP/1.1" 302 -

80.137.59.25 - - [12/Apr/2004:13:24:24 +0200] "GET /phpmyadmin/index.php?lang=de-iso-8859-1&server=1 HTTP/1.1" 200 6688

80.137.59.25 - - [12/Apr/2004:13:24:29 +0200] "POST /phpmyadmin/index.php HTTP/1.1" 200 6551

213.23.164.238 - - [12/Apr/2004:13:26:15 +0200] "POST /phpmyadmin/left.php HTTP/1.1" 200 43347

213.23.164.238 - - [12/Apr/2004:13:26:17 +0200] "GET /phpmyadmin/css/phpmyadmin.css.php?js_frame=left&num_dbs=0 HTTP/1.1" 200 940

213.23.164.238 - - [12/Apr/2004:13:26:17 +0200] "GET /phpmyadmin/images/button_smallbrowse.png HTTP/1.1" 200 208

213.23.164.238 - - [12/Apr/2004:13:26:18 +0200] "GET /phpmyadmin/tbl_properties_structure.php?lang=de-iso-8859-1&server=1&db=stufe12&table=stufe12_blacklist HTTP/1.1" 200 25040

213.23.164.238 - - [12/Apr/2004:13:27:37 +0200] "GET /phpmyadmin/tbl_properties_structure.php?lang=de-iso-8859-1&server=1&db=stufe12&table=stufe12_blacklist HTTP/1.1" 200 6548

213.23.164.238 - - [12/Apr/2004:13:27:43 +0200] "POST /phpmyadmin/index.php HTTP/1.1" 302 -

213.23.164.238 - - [12/Apr/2004:13:27:43 +0200] "GET /phpmyadmin/index.php?lang=de-iso-8859-1&server=1 HTTP/1.1" 200 2406

213.23.164.238 - - [12/Apr/2004:13:27:43 +0200] "GET /phpmyadmin/css/phpmyadmin.css.php?lang=de-iso-8859-1&js_frame=right HTTP/1.1" 200 6376

213.23.164.238 - - [12/Apr/2004:13:27:43 +0200] "GET /phpmyadmin/queryframe.php?lang=de-iso-8859-1&server=1&hash=0e6d67ccc9767d55bb88a49764e681f11081769263 HTTP/1.1" 200 2086

213.23.164.238 - - [12/Apr/2004:13:27:43 +0200] "GET /phpmyadmin/left.php?lang=de-iso-8859-1&server=1&hash=0e6d67ccc9767d55bb88a49764e681f11081769263 HTTP/1.1" 200 2397

213.23.164.238 - - [12/Apr/2004:13:27:44 +0200] "GET /phpmyadmin/css/phpmyadmin.css.php?js_frame=left&num_dbs=0 HTTP/1.1" 200 940

213.23.164.238 - - [12/Apr/2004:13:27:44 +0200] "GET /phpmyadmin/main.php?lang=de-iso-8859-1&server=1 HTTP/1.1" 200 14830

213.23.164.238 - - [12/Apr/2004:13:27:44 +0200] "GET /phpmyadmin/css/phpmyadmin.css.php?lang=de-iso-8859-1&js_frame=right HTTP/1.1" 200 6376

213.23.164.238 - - [12/Apr/2004:13:27:47 +0200] "POST /phpmyadmin/left.php HTTP/1.1" 200 7580

213.23.164.238 - - [12/Apr/2004:13:27:47 +0200] "GET /phpmyadmin/css/phpmyadmin.css.php?js_frame=left&num_dbs=0 HTTP/1.1" 200 940

213.23.164.238 - - [12/Apr/2004:13:27:47 +0200] "GET /phpmyadmin/db_details_structure.php?lang=de-iso-8859-1&server=1&db=mysql HTTP/1.1" 200 29256

213.23.164.238 - - [12/Apr/2004:13:27:51 +0200] "POST /phpmyadmin/left.php HTTP/1.1" 200 31645

213.23.164.238 - - [12/Apr/2004:13:27:52 +0200] "GET /phpmyadmin/css/phpmyadmin.css.php?js_frame=left&num_dbs=0 HTTP/1.1" 200 940

213.23.164.238 - - [12/Apr/2004:13:27:52 +0200] "GET /phpmyadmin/db_details_structure.php?lang=de-iso-8859-1&server=1&db=praxis HTTP/1.1" 200 25023

213.23.164.238 - - [12/Apr/2004:13:27:53 +0200] "GET /phpmyadmin/tbl_properties_structure.php?lang=de-iso-8859-1&server=1&db=praxis&table=phpkit_config HTTP/1.1" 200 90811
SteGra
 
Posts: 48
Joined: 26. December 2003 16:05


Return to phpMyAdmin

Who is online

Users browsing this forum: No registered users and 1 guest