Problem mit Passwortvergabe für root

Und alles was mit phpMyAdmin seine Verwandtschaft findet hat hier seinen Platz.

Problem mit Passwortvergabe für root

Postby zp04 » 21. January 2004 22:31

Hallo,

bevor hier einige aufstöhnen wegen diesem Thema, ich habe das Forum ausführlich studiert und keine Lösung für mein Problem gefunden. Folgendes:

Ich kann einfach kein Passwort vergeben, auf das der phpmyadmin anspringt. Als ich für den Superuser root eines vergeben hatte, kam bei phpmyadmin immer nur: Access denied for user: root@localhost (Using password: NO) Also als erstes die config.inc.php angepasst: auth_type = config, user=root, password=geheim -> interessierte überhaupt nicht. Also Passwort raus, auth_type auf cookie -> interessierte überhaupt nicht. Es kam nicht mal ne Abfrage, gleich: Access denied for user: root@localhost (Using password: NO)

Nach langem Suchen im Web konnte ich dann wenigstens das Passwort im mysql auf leer zurücksetzen, es herrscht also wieder die Ausgangssituation. Als nächstes habe ich einen zweiten Nutzer angelegt, den auth_type auf http bzw. cookie gesetzt und sogar den Benutzernamen aus der config.inc.php entfernt. Es interessiert das Scheissding nicht, er startet einfach den admin und loggt sich als root mit leerem Passwort ein. Ich weiß echt nicht mehr weiter. Vll. aber ihr. Wäre echt schön.

Achja: System: Win2000 SP3, Minixampp (irgendwann im Sommer 03 - mysql version 4.0.15, phpmyadmin 2.5.3)

Grüße, Peer

PS: Das Ganze hat mich mittlerweile fast 3 Stunden gekostet. *Frust*
zp04
 
Posts: 2
Joined: 21. January 2004 22:13

Postby DJ DHG » 22. January 2004 01:11

Moin Moin

ich mache das immer wie folgt.
erst lege ich mir alle user an die brauche, und lösche alle die als
default vorher drin wahren. (oder ändere sie an wie den root)
start mysql neu (ich weiss muss mann nicht unbedingt machen),
ist nur eine angewohnheit.
dann rufe ich phpmyadmin erneut auf, fehlermeldung

Access denied for user: bla bla bla

kommt wie erwartet.
dann ändere ich die config.inc.php wie folgt ab.

Code: Select all
$cfg['Servers'][$i]['controluser']   = '';
$cfg['Servers'][$i]['controlpass']   = '';
$cfg['Servers'][$i]['auth_type']     = 'cookie';
$cfg['Servers'][$i]['user']          = '';
$cfg['Servers'][$i]['password']      = '';



hatte bis jetzt noch kein probs damit.

mfg DJ DHG
User avatar
DJ DHG
AF Moderator
 
Posts: 2455
Joined: 27. December 2002 13:50
Location: Kiel

Postby grawlix » 22. January 2004 02:03

Bin wohl doch nicht der einzigste mit dem Problem. Habe nun nach der Änderung in der config.inc.php jedoch sobald ich mich in phpmyadmin einwähle "Ab diesem Puntk müssen Cookies aktiviert sein" stehen. Wenn ich dann mein Wunschpasswort und Login eingebe komm ich nicht rein...

Ich weiß ist ein NEwbie Thread, aber ich bin auch kein Informatiker und hab das Forum wie mein Vorredner aebenfalls durchforstet.

System:Os: win xp pro
Foxserv v.3.0
(Apache: 2.0.39
phpmyadmin 2.2.6)
Browser: IE 5.5 (Cookies eingestellt!!!)


Vielen Dank vorab für eine Antwort

Dirk
grawlix
 
Posts: 1
Joined: 22. January 2004 01:14
Location: NRW

Postby DJ DHG » 22. January 2004 02:53

grawlix wrote:Foxserv v.3.0


Foxserv 3.0? ein mitbewerber ? :mrgreen:
hab die da kein forum oder?
ist nicht böse gemeint, aber kann es sein das du dich verirrt hast?

ich weiss zwar nicht wie ihr euer phpmyadmin/mysql einstellt,
aber so wie ich es oben beschrieben habe, funzt es echt ohne probs.

mfg DJ DHG

ps: ich bin auch kein Informatiker.
User avatar
DJ DHG
AF Moderator
 
Posts: 2455
Joined: 27. December 2002 13:50
Location: Kiel

Postby zp04 » 22. January 2004 23:56

Es funktioniert nicht! Sobald ich für root ein Passwort vergebe, kann mich phpmyadmin nicht mehr anmelden. Das ist ja soweit ok. Aber: es steht in der Fehlermeldung:

Fehler

MySQL meldet:

#1045 - Access denied for user: 'root@localhost' (Using password: NO)

Und das kapier ich nicht, warum sagt der "Using password: NO" und nicht "YES"? Und warum kommt keine Abfrage zum Einloggen, obwohl auth_type = cookie bzw. http gesetzt ist? Können die Daten zum Einloggen noch in irgendeiner anderen Datei liegen? Bin hier echt am verzweifeln, alle schreiben wie toll es geht und hier funzt nichts. Hier noch meine config.inc.php (kommentierte Sachen gelöscht):

<?php
/* $Id: config.inc.php,v 1.198 2003/08/05 14:08:22 nijel Exp $ */
// vim: expandtab sw=4 ts=4 sts=4:

if (!isset($old_error_reporting)) {
error_reporting(E_ALL);
@ini_set('display_errors', '1');
}

$cfg['PmaAbsoluteUri'] = '';
$cfg['PmaAbsoluteUri_DisableWarning'] = TRUE;
$cfg['PmaNoRelation_DisableWarning'] = FALSE;
$cfg['blowfish_secret'] = 'geheim';

$i = 0;
$i++;
$cfg['Servers'][$i]['host'] = 'localhost';
$cfg['Servers'][$i]['port'] = '';
$cfg['Servers'][$i]['socket'] = '';
$cfg['Servers'][$i]['connect_type'] = 'tcp';
$cfg['Servers'][$i]['compress'] = FALSE;
$cfg['Servers'][$i]['controluser'] = '';
$cfg['Servers'][$i]['controlpass'] = '';
$cfg['Servers'][$i]['auth_type'] = 'http';
$cfg['Servers'][$i]['user'] = '';
$cfg['Servers'][$i]['password'] = '';
$cfg['Servers'][$i]['only_db'] = '';
$cfg['Servers'][$i]['verbose'] = '';
$cfg['Servers'][$i]['pmadb'] = 'phpmyadmin';
$cfg['Servers'][$i]['bookmarktable'] = 'PMA_bookmark';
$cfg['Servers'][$i]['relation'] = 'PMA_relation';
$cfg['Servers'][$i]['table_info'] = 'PMA_table_info';
$cfg['Servers'][$i]['table_coords'] = 'PMA_table_coords';
$cfg['Servers'][$i]['pdf_pages'] = 'PMA_pdf_pages';
$cfg['Servers'][$i]['column_info'] = 'PMA_column_info';
$cfg['Servers'][$i]['history'] = 'PMA_history';
$cfg['Servers'][$i]['verbose_check'] = TRUE;
$cfg['Servers'][$i]['AllowDeny']['order'] = '';
$cfg['Servers'][$i]['AllowDeny']['rules'] = array();


Irgendeiner noch eine Idee???

Grüße, Peer
zp04
 
Posts: 2
Joined: 21. January 2004 22:13

Postby thkraft » 23. January 2004 08:07

zp04 wrote:$cfg['Servers'][$i]['controluser'] = '';
$cfg['Servers'][$i]['controlpass'] = '';
$cfg['Servers'][$i]['auth_type'] = 'http';
$cfg['Servers'][$i]['user'] = '';
$cfg['Servers'][$i]['password'] = '';


Ich denke du musst beim HTTP-mode noch einen Controluser einrichten. Siehe auch Dokumentaton unter : http://www.phpmyadmin.net/documentation/#config

$cfg['Servers'][$i]['controluser'] string
$cfg['Servers'][$i]['controlpass'] string
This special account is used for 2 distinct purposes: to make possible a multi-user installation (http or cookie authentication mode) and also for all relational features (see $cfg['Servers'][$i]['pmadb']).

When using HTTP or cookie authentication modes (or 'config' authentication mode since phpMyAdmin 2.2.1), you need to supply the details of a MySQL account that has SELECT privilege on the mysql.user (all columns except "Password"), mysql.db (all columns) & mysql.tables_priv (all columns except "Grantor" & "Timestamp") tables. This account is used to check what databases the user will see at login.
Please see the install section on "Using HTTP authentication" for more information.

Note that if you try login to phpMyAdmin with this "controluser", you could get some errors, depending the exact privileges you gave to the "controluser". phpMyAdmin does not support a direct login with the "controluser".

In versions before 2.2.5, those were called "stduser/stdpass".
www.bbz95.de
alles rund um den Mädchen- und Damenbasketball in Leverkusen
User avatar
thkraft
 
Posts: 5
Joined: 07. February 2003 07:45
Location: Leverkusen

Postby Majorxxl » 08. May 2005 01:24

ich sag mal MEGA Danke

ich hab bei meinem Apache auch lokker nen PW eingetippert

und hoppla
KEIN LOGIN fenster sondern immer denn SQL Fehler 1045. Access Denied ERROR

lol

durch dieses SUPER Forum hab ich nun nen Nutzernamen und PW sowie das FU
cookie drin stehen und SUPER ALLES COOL hab wieder vollzugriff.....

danke an alle

in diesem sinne HF Majorxxl
Majorxxl
 
Posts: 2
Joined: 07. April 2005 03:49


Return to phpMyAdmin

Who is online

Users browsing this forum: No registered users and 2 guests