UTF-8 will nicht so wie ich gern will

Und alles was mit phpMyAdmin seine Verwandtschaft findet hat hier seinen Platz.

UTF-8 will nicht so wie ich gern will

Postby hanseate82 » 24. February 2010 02:32

Hallo..

Das Thema gab es ja bestimmt schon oft, aber alles lesen hat mir nicht zu einer Lösung verholfen.

Ich nutze PHPMyAdmin von meinem Hoster in der Version 2.8.2.4, und habe alles was ich finden konnte in MySQL auf UTF-8 umgestellt.
Weiterhin habe ich in den Webseiten (php) folgende Angaben eingebaut:

Code: Select all
header('Content-Type: text/html; charset=UTF-8');
<?php echo "<?xml version=\"1.0\" encoding=\"UTF-8\"?>\n";?>
<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />


Weil alles nicht half habe ich eine htaccess mit dem Inhalt

Code: Select all
AddDefaultCharSet utf-8
AddCharSet utf-8 .shtml .htm .html .php


hochgeladen. Und sie schlägt sich auch auf den HTTP Header nieder, in dem vorher kein Zeichensatz angegeben war:

Code: Select all
HTTP/1.1·200·OK(CR)(LF)
Date:·Wed,·24·Feb·2010·01:14:37·GMT(CR)(LF)
Server:·Apache/2.2.3·(CentOS)(CR)(LF)
X-Powered-By:·PHP/5.1.6(CR)(LF)
Expires:·Thu,·19·Nov·1981·08:52:00·GMT(CR)(LF)
Cache-Control:·no-store,·no-cache,·must-revalidate,·post-check=0,·pre-check=0(CR)(LF)
Pragma:·no-cache(CR)(LF)
Set-Cookie:·PHPSESSID=a19d7pboqop1le7t4fbmqa4234;·path=/(CR)(LF)
Connection:·close(CR)(LF)
Transfer-Encoding:·chunked(CR)(LF)
Content-Type:·text/html;·charset=UTF-8(CR)(LF)
(CR)(LF)


Trotz allem werden Umlaute, die über Formulare auf den Seiten eingegeben werden, in PHPMyAdmin so angezeigt: öüöäüß
und alles was in PHPMyAdmin eingegeben wird (Umlaute), sieht dann auf der Webseite so aus: ��������

Ich weiß absolut nicht mehr was ich noch tun kann um endlich eine funktionierende Seite mit UTF-8 zu bekommen.


Danke für jeden Tip
h.
hanseate82
 
Posts: 1
Joined: 23. February 2010 15:14

Return to phpMyAdmin

Who is online

Users browsing this forum: No registered users and 1 guest