Probleme mit phpMyAdmin

Und alles was mit phpMyAdmin seine Verwandtschaft findet hat hier seinen Platz.

Probleme mit phpMyAdmin

Postby Madner » 02. June 2008 07:17

Tach allerseits,
ich sitz grad in meiner Ausbildung und muss diese Woche PHP mit MySQl zusammen verwenden, nur leider habe ich da ein kleines Problem...
Immer wenn ich auf "phpMyAdmin" klicke kommt folgender Fehler:

"phpMyAdmin - Fehler

Die Erweiterung mysql kann nicht geladen werden. Bitte überprüfen Sie Ihre PHP-Konfiguration. - Dokumentation"

Hab xampp schon 2 mal neu installiert, rechner neugestartet, MySQl Manuell runtergeladen usw. usw. usw.
Mein Dozent hat auch keine Ideen mehr wie ich das ganze zum laufen bringen kann ;)
PHP ansich funktioniert mit xampp, aber auch im Menu zeigen sich merkwürdige Fehler:
Wenn ich z.B. auf "CD-Verwaltung" oder "Biorhythmus" klicke sehe ich nur haufenweise PHP-Code, was denk ich mal nicht sein soll.

Kann mir da jemand nen Tip geben wie ich weiter vorgehen kann?

Hab Windows XP Prof SP2 installiert.

EDIT: sry, zu spät gesehn, dass es auch ne phpMyAdmin-Rubrik gibt...kann verschoben werden...
Madner
 
Posts: 2
Joined: 02. June 2008 07:10

Postby Wiedmann » 02. June 2008 11:19

Da fliegt noch eine alte/falsche "php.ini" in dem System rum.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby Madner » 02. June 2008 12:32

Naja inwiefern falsche php.ini, meine kollegen benutzen alle das gleich xampp und da geht alles...

Hier ma die Versionsangaben...

Apache 2.2.8
MySQL 5.0.51a
PHP 5.2.5 + PHP 4.4.8 + PEAR
PHP-Switch win32 1.0 (please use the "php-switch.bat")
XAMPP Control Version 2.5 from www.nat32.com
XAMPP Security 1.0
SQLite 2.8.15
OpenSSL 0.9.8g
phpMyAdmin 2.11.4
Madner
 
Posts: 2
Joined: 02. June 2008 07:10

Problem gelöst!

Postby bennyn » 30. August 2008 15:05

Ich hatte gerade genau (!) das gleiche Problem und dabei hatte ich eine völlig neue Installation von XAMPP aufgesetzt (ohne vorher eine ältere Version installiert zu haben).

Zum Glück habe ich eine Lösung gefunden! :)


Ich habe das XAMPP-Frontend geöffnet:

http://localhost/xampp/ und dann auf phpinfo() geklickt.


Dort habe ich Folgendes gelesen:

Loaded Configuration File C:\Programme\PHP\php.ini


Die Datei "php.ini" in "C:\Programme\PHP\" habe ich dann mit der "php.ini" aus "C:\xampp\apache\bin\" überschrieben.


Fertig!
bennyn
 
Posts: 1
Joined: 30. August 2008 14:44
Location: Potsdam

Postby deepsurfer » 31. August 2008 15:07

Dort habe ich Folgendes gelesen:

Loaded Configuration File C:\Programme\PHP\php.ini


Die Datei "php.ini" in "C:\Programme\PHP\" habe ich dann mit der "php.ini" aus "C:\xampp\apache\bin\" überschrieben.


Und eben das ist doch unsinnig...sorry für wortwahl.

XAMPP liefert eine eigene PHP.INI mit die in einem Definierten Pfad aufgerufen werden sollte, ABER, dadurch das XAMPP nicht auf Systemebene eingreift und sich seine eigenen Pfade in die Registry setzt, geht der XAMPP-PHPparser seinen Urinstinkt nach und sucht vorab in den Pfad Variablen des Systems und wird Fündig und holt sich die vorhanden (aber falsche) PHP.INI.

Den weg einfach, die nicht mehr zu gebrauchende PHP.INI, durch den Inhalt der richtigen XAMPP-PHP.INI zu ersetzen ist zwar möglich aber entspricht nicht dem Gedanken der Nativen XAMPP Benutzung.

Daher greift wieder die Aussage von ~Wiedmann~ das eben bei diesem Fehler die falsche PHP.INI genommen wird.

Folglich, einfach die veraltete PHP.INI löschen, da man von ausgehen kann das man den "alten" PHPparser DeInstalliert hat und schon holt sich der XAMPP-PHPparser sich die richtige PHP.INI aus dem XAMPP Paket.
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
XAMPP Version: 5.6.3
Operating System: Win-XP / Win7 / Linux -Debian


Return to phpMyAdmin

Who is online

Users browsing this forum: No registered users and 4 guests