Mache alles richtig? Nichts funktioniert. Bin verzweifelt.

Und alles was mit phpMyAdmin seine Verwandtschaft findet hat hier seinen Platz.

Mache alles richtig? Nichts funktioniert. Bin verzweifelt.

Postby marekm » 27. September 2007 10:45

Hallo!
Kann mir jemand helfen?? Bin total verzweifelt und beginne an meiner Intelligenz zu zweifeln.


Auf einem Windows Rechner mit Win XP Prof. SP2 habe ich eine lokale Testumgebung – Apache, PHP & Mysql

aufzubauen versucht. LEIDER OHNE ERFOLG.


Die Programme liegen wie folgend:


F:\Programme\Apache Group\Apache2

F:\Server\mysql

F:\Server\phpMyAdmin

F:\Server\php5

F:\Server\mysql


_SERVER["SCRIPT_FILENAME"] F:/Server/htdocs/info.php

_SERVER["DOCUMENT_ROOT"] F:/Server/htdocs



extension_dir F:\Server\php5\ext #sind eigentlich die slashes richtig gelegt???

Server Root F:/Programme/Apache Group/Apache2

SERVER_SOFTWARE Apache/2.0.59 (Win32) PHP/5.2.3



HTTP_USER_AGENT Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.8.1.6) Gecko/20070725

Firefox/2.0.0.6

MySQL Support Client API version 5.0.37

Client API library version 5.0.37
Client API header version 5.0.36

PATH

F:\Programme\Perl\bin\;C:\WINDOWS\system32;C:\WINDOWS;C:\WINDOWS\System32\Wbem;F:\Server\mysql\bin;F:\Pr

ogramme\Apache Group\Apache2\bin\;F:\Server\phpMyAdmin;
-----------------------------------------------------------------------------------------

ALLES WIRD SO KONFIGURIERT WIE ES AUF DER SITE:

http://www.wintotal.de/Artikel/lokalete ... gebung.php

EMPFOHLEN WIRD.




Wenn ich aufrufe:
http://localhost/phpmyadmin/

bekomme ich folgende Meldung:


Not Found

The requested URL /phpmyadmin/ was not found on this server.
Apache/2.0.59 (Win32) PHP/5.2.3 Server at localhost Port 80

------------------------------------------------------------------------
Wenn ich aufrufe:
http://localhost/F:/Server/phpMyAdmin/

bekomme ich folgende Meldung:

Forbidden

You don't have permission to access /F:/Server/phpMyAdmin/ on this server.
Apache/2.0.59 (Win32) PHP/5.2.3 Server at localhost Port 80

------------------------------------------------------------------------------

Wenn ich aufrufe:
http://localhost/
bekomme ich:
Index of /

Icon Name Last modified Size Description[DIR] administrator/

19-Aug-2007 23:12 -
[DIR] backups/ 26-Sep-2007 17:45 -
[DIR] cache/ 26-Sep-2007 17:48 -
[DIR] cgi-bin/ 26-Sep-2007 17:45 -
[DIR] components/ 26-Sep-2007 17:48 -
[DIR] dodatki/ 26-Sep-2007 17:48 -
[DIR] editor/ 26-Sep-2007 17:48 -
[DIR] errors/ 26-Sep-2007 17:45 -
[DIR] help/ 26-Sep-2007 17:48 -
[DIR] images/ 26-Sep-2007 17:48 -
[ ] info.php 29-Aug-2007 22:54 22

(es ist eine HomePage die ich per FTP von einem Server runter geladen habe)



Apache/2.0.59 (Win32) PHP/5.2.3 Server at localhost Port 80
----------------------------------------------------------------




Wenn ich aufrufe:
http://localhost/manual/
bekomme ich die Dokumentation
---------------------------------------

Wenn ich aufrufe:
http://localhost/my_docs/

bekomme ich die Dokumentation
-------------------------------------------------------------------

Wenn ich aufrufe:
http://localhost/info.php
bekomme ich die Dokumentation ueber PHP5
-----------------------------------------------


Einzeln funktionieren alle Komponenten!!


Das Aufrufen von phpMyAdmin GEHT NICHT!

Warum??
Kann mir jemand helfen. Ich bin ein Newbe. Habe nur Ahnung wenn es um Windows geht.


Danke in voraus
marek
Last edited by marekm on 27. September 2007 21:43, edited 1 time in total.
marekm
 
Posts: 5
Joined: 27. September 2007 10:36
Location: Berlin

Postby Wiedmann » 27. September 2007 10:51

Das Aufrufen von phpMyAdmin GEHT NICHT!

Weil du den Alias nicht angelegt hast?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby sari42 » 27. September 2007 12:10

ainfach alles wegputzen und XAMPP installieren ;)
sari42
 
Posts: 800
Joined: 27. November 2005 18:28

Postby marekm » 27. September 2007 12:58

Wiedmann wrote:
Das Aufrufen von phpMyAdmin GEHT NICHT!

Weil du den Alias nicht angelegt hast?


Wie kommst Du darauf??
Ich habe

#
# PhpMyAdmin
#
<IfModule mod_alias.c>
Alias /myadmin "F:\Server\phpMyAdmin"
</IfModule>
<Directory "F:\Server\phpMyAdmin">
Options None
AllowOverride None
order deny,allow
deny from all
allow from 127.0.0.1
</Directory>

reingeschriben.

Ist das o´k?

marek
marekm
 
Posts: 5
Joined: 27. September 2007 10:36
Location: Berlin

Postby marekm » 27. September 2007 13:00

sari42 wrote:ainfach alles wegputzen und XAMPP installieren ;)



Und wo ist die Ehre geblieben??
Bin ich so doof??

Marek
marekm
 
Posts: 5
Joined: 27. September 2007 10:36
Location: Berlin

Postby sari42 » 27. September 2007 13:31

hatte dein OP nur überflogen (war mir zu lang ;) ...

versuch ´s doch mal mit http://localhost/myadmin/
sari42
 
Posts: 800
Joined: 27. November 2005 18:28

Postby marekm » 27. September 2007 21:46

sari42 wrote:hatte dein OP nur überflogen (war mir zu lang ;) ...

versuch ´s doch mal mit http://localhost/myadmin/


Das funktioniert auch nicht!! (als ob der Apache - Server nichts von dem Programm phpMyAdmin wuesste)

Trotzdem Danke!
marek
marekm
 
Posts: 5
Joined: 27. September 2007 10:36
Location: Berlin

Postby kschroeder » 28. September 2007 08:13

Hallo,

soviel ist doch gar nicht verkehrt, dass man so verzweifeln muss :wink:

Aber ganz logisch betrachtet, hast Du in der Apache-Config einen Alias versucht anzulegen, der myadmin heisst und auf Dein Phpmyadmin zeigt.
Alias /myadmin "F:\Server\phpMyAdmin"


Folglich muss, wie sari42 schon gesagt hat, phpmyadmin über http://localhost/myadmin/ aufgerufen werden.

Wenn das nicht funktioniert, funktioniert schlicht Dein Alias nicht.

Ich nehme schwer an, dass Dein phpmyadmin funktionieren würde, wenn Du die Dateien innerhalb des Docroots liegen hättest.

Du wirst Dir wohl oder übel mal die Alias-Geschichte nochmal anschauen müssen.

Versuch doch mal folgendes:

Alias /phpmyadmin "F:/Server/phpMyAdmin/"
<Directory "F:/Server/phpMyAdmin">
AllowOverride None
Order allow,deny
Allow from all
</Directory>


Ein entscheidender Unterschied ist, dass Du hier zunächsteinmal allen erlaubst, den Alias zu verwenden. Wenn das funktioniert, dann kannst Du ja immer noch wieder einschränken.
kschroeder
 
Posts: 250
Joined: 11. May 2007 13:33

Postby marekm » 28. September 2007 19:37

Hallo,
danke, das hat einen Schritt weiter geholfen.
Leider bekomme ich jetzt eine neue Fehlermeldung (nachdem ich phpMyAdmin starte):

"php_mysql.dll kann nicht geladen werden" (nach uebersaetzung des Code-Fehlers)
(quote:Die Erweiterung mysql kann nicht geladen werden. Bitte �berpr�fen Sie Ihre PHP-Konfiguration. - Dokumentation)

die Datei steckt 100% -tig im Verzeichnis /PHP5/ext und zusaetzlich im /PHP5 (Stammverzeichnis).

Wenn ich info.php aufrufe finde ich trotzdem keinen Hinweis, dass php_mysql.dll als Extension geladen worden ist. Das Semicolon (vor der Extention) habe ich geloescht!

Ist eigentlich PHP5 zu phpMyAdmin compatibel (ob unterstuetzt wird??)
Vielleicht geht es nicht die zwei Programme zu verheiraten??

Gruesse
marek


P.S.
Folgendes wäre vielleicht noch relevant:
OS: Win XP Prof. SP2
PHP Version: 5.1.2
MySql Version: 5.0.18
PhpMyAdmin Version: 2.8.0.3

und folgende extensions auskommentiert:

extension=php_mysql.dll
extension=php_mysqli.dll









kschroeder wrote:Hallo,

soviel ist doch gar nicht verkehrt, dass man so verzweifeln muss :wink:

Aber ganz logisch betrachtet, hast Du in der Apache-Config einen Alias versucht anzulegen, der myadmin heisst und auf Dein Phpmyadmin zeigt.
Alias /myadmin "F:\Server\phpMyAdmin"


Folglich muss, wie sari42 schon gesagt hat, phpmyadmin über http://localhost/myadmin/ aufgerufen werden.

Wenn das nicht funktioniert, funktioniert schlicht Dein Alias nicht.

Ich nehme schwer an, dass Dein phpmyadmin funktionieren würde, wenn Du die Dateien innerhalb des Docroots liegen hättest.

Du wirst Dir wohl oder übel mal die Alias-Geschichte nochmal anschauen müssen.

Versuch doch mal folgendes:

Alias /phpmyadmin "F:/Server/phpMyAdmin/"
<Directory "F:/Server/phpMyAdmin">
AllowOverride None
Order allow,deny
Allow from all
</Directory>


Ein entscheidender Unterschied ist, dass Du hier zunächsteinmal allen erlaubst, den Alias zu verwenden. Wenn das funktioniert, dann kannst Du ja immer noch wieder einschränken.
Last edited by marekm on 28. September 2007 20:28, edited 1 time in total.
marekm
 
Posts: 5
Joined: 27. September 2007 10:36
Location: Berlin

Postby sari42 » 28. September 2007 19:50

deshalb "XAMPP" installieren ;)

offenbar besteht win-apache drauf, daß die libmysql.dll (und php5apache2_2.dll) im apache/bin DIR stehen, siehe xampp installation.
Ist eigentlich PHP5 zu phpMyAdmin compatibel
jo, in Zukunft sogar ausschließlich.
sari42
 
Posts: 800
Joined: 27. November 2005 18:28


Return to phpMyAdmin

Who is online

Users browsing this forum: No registered users and 1 guest