MySQL und PHPMyAdmin funktioniert nicht

Und alles was mit phpMyAdmin seine Verwandtschaft findet hat hier seinen Platz.

MySQL und PHPMyAdmin funktioniert nicht

Postby matt1981 » 19. July 2007 20:52

Hallo an alle fleißigen Helfer,

habe ein Problem mit phpMyAdmin nach der Installation der neuesten Version von XAMPP.

Ich bekomme folgende Fehlermeldung:
Die Erweiterung mysql kann nicht geladen werden. Bitte überprüfen Sie Ihre PHP-Konfiguration

Nun habe ich schon so viele Dinge versucht und es geht nicht:
-Habe die php_mysql.dll heruntergeladen
-Habe extension=php_mysql.dll eingetragen bzw den Kommentar entfernt
-Habe auch den Pfad geändert auf Windows/System32

all diese Punkte haben nicht bewirkt. Weiß vielleicht noch jemand eine andere Lösung? Das Wäre echt Klasse. Freue mich sehr über Antworten

Vielen Dank im Vorraus
matt1981
 
Posts: 13
Joined: 11. April 2005 10:50

Postby sari42 » 27. July 2007 17:12

befrag mal <?php phpinfo(); ?>
welche php.ini gültig ist und wo die dll´s gesucht werden.
sari42
 
Posts: 800
Joined: 27. November 2005 18:28

Postby matt1981 » 30. July 2007 19:13

Vielen Dank erst mal für Deine Antwort.
Jetzt weiß ich nicht genau was du meinst da ich noch Neuling bin, aber meinst du eine von den beiden Angaben die ich hier unten eingefügt habe? Sonst habe ich in der phpinfo nichts gefunden was du eventuell meinen könntest.

Configuration File (php.ini) Path C:\WINDOWS
Loaded Configuration File C:\Programme\PHP\php.ini

Bei mir war es auch so, dass die dll datei vorhanden war und auch in der php.ini datai nicht auskommentiert ist.

Würde mich über ne antwort von dir freuen
matt1981
 
Posts: 13
Joined: 11. April 2005 10:50

Postby sari42 » 31. July 2007 20:02

>Configuration File (php.ini) Path C:\WINDOWS
wenn nix anderes vorgegeben wurde,

>Loaded Configuration File C:\Programme\PHP\php.ini
sagt eigentlich alles, xampp nutzt übrigens:
LW:\pfad_zu\xampp(lite)\apache\bin\php.ini

die .dlls werden im extension_dir gesucht, bei mir in:
LW:\pfad_zu\xampp(lite)\php\ext\
sari42
 
Posts: 800
Joined: 27. November 2005 18:28

Postby matt1981 » 01. August 2007 15:26

Hallo Sari42,

was ich aber nicht verstehe ist wenn ich die php.ini öffne und nach dem Extension_dir schaue steht bei mir auch drin:

-C:\Programm\Xampp\PHP\ext
- zudem sind die besagten Dlls vorhanden
- und die Zeile extension=php_mysql.dll ist nicht auskommentiert

Ich weiß da echt nicht mehr weiter was ich noch machen kann.
Wenn du vielleicht noch was wüsstest wäre ich echt sehr dankbar für eine Antwort
matt1981
 
Posts: 13
Joined: 11. April 2005 10:50

Postby sari42 » 01. August 2007 16:34

>was ich aber nicht verstehe ist wenn ich
>die php.ini
welche?

>steht bei mir auch drin:
>-C:\Programm\Xampp\PHP\ext
relevant ist nur was phpinfo() sagt.

Irgendwo (in den FAQs?) hab ich gelesen, daß Vista "C:\Programme\Xampp" nicht mag.
sari42
 
Posts: 800
Joined: 27. November 2005 18:28

Postby matt1981 » 01. August 2007 19:36

Ich meine das php. ini wenn ich unter c den ordner xampp aufmache und dann den ordner php öffne und dann die datei php.ini wo das alles drinsteht mit extension dir.

Wo soll das extension dir bzw der pfad wo die dll vorhanden sind denn im phpinfo stehen? Wenn ich xampp starte und den Link phpinfo() anklicke finde ich da drunter nicht. Ich glaub vielleicht bin ich einfach nur zu doof das zu finden. Unter welcher Ruprik steht denn der Pfad, steht der gleich ganz oben oder viell auch ganz unten unter der Überschrift PHP Variables?

Bin dir echt sehr dankbar für deine Hilfe
matt1981
 
Posts: 13
Joined: 11. April 2005 10:50

Postby sari42 » 01. August 2007 20:39

matt1981 wrote:Ich meine das php. ini wenn ich unter c den ordner xampp aufmache und dann den ordner php öffne und dann die datei php.ini wo das alles drinsteht mit extension dir.
oben erzählst Du aber, daß eine ganz andere php.ini verwendet wird (Loaded Configuration File C:\Programme\PHP\php.ini ). Am besten deinstalierst Du den ganzen Schrott, besonders "Programme\PHP",
und installierst nur xampp 163a in c:\
sari42
 
Posts: 800
Joined: 27. November 2005 18:28

Postby matt1981 » 01. August 2007 22:50

o da habe ich mich wohl verschrieben.

ich habe die installation unter C:\Programme
Das andere war nur ein Schreibfehler

Aber habe es schon direkt und C:\ versucht und das ging auch nicht jetzt liegt es unter Programme und habe xampp nur einmal drauf. Das war ein Missverständnis von mir.

Hoffe Du hast noch irgend ne Lösung für das Problem :oops:
matt1981
 
Posts: 13
Joined: 11. April 2005 10:50

Postby matt1981 » 01. August 2007 23:04

Mal ne doofe Frage, würde es irgendwas bringen wenn ich die Error LogFile noch poste oder hat das damit gar nichts zu tun?
matt1981
 
Posts: 13
Joined: 11. April 2005 10:50

Postby WaldschratMX » 14. August 2007 04:23

Hallo zusammen.
Ich habe genau das selbe Problem und suche jetzt seit 5 Stunden nach einer Lösung.
Habe viele Ansätze gefunden, nichts hat funktioniert.
Ich hab die DLL's etc. aus dem Windows Verzeichnis gelöscht und in ein anderes gesteckt (natürlich jedes mal die config geändert und geprüft ob der Pfad zu der zu ladenden php.ini richtig ist), ich habe mir ne neue php_mysql.dll und libmysql.dll runtergeladen, in jedes Verzeichnis gepackt was nicht schreibgeschützt war (im übertriebenen Sinne natürlich). Habe Neustarts gemacht, aktualisiert, deinstalliert, neu installiert, in anderer Reihenfolge installiert. Ausserdem noch die apache und mysql configs überprüft.

Momentan siehts halt so aus (habe keine Nerven mehr, darum auch das Hilfegesuch jetzt):
Configuration File (php.ini) Path C:\WINDOWS
Loaded Configuration File C:\WINDOWS\php.ini
extension_dir c:\php\ext

die Verzeichnisse sind alle richtig (also die Dateien liegen da) und die php.ini im Windows Verzeichnis ist die einzige php.ini auf meinem Rechner.
Fehlermeldung ist halt: "Die Erweiterung mysql kann nicht geladen werden. Bitte überprüfen Sie Ihre PHP-Konfiguration."
(Achja, XAMMP oso hab ich nicht, alles manuel installiert nach anleitungen die ich im Internet gefunden habe).
Den selben Fehler hab ich übrigens auch mit mySQL Admin.

Bin echt am verzweifeln und verfluche mySQL schon. Aber noch hat es mich nicht besiegt :)

Schonmal vielen Dank im Vorraus. Falls noch Fragen sind, oder ich Angaben vergessen habe nur bescheid sagen.


Vll. noch: benutzte Windows XP SP2, Apache 2.24, mySQL 5.0.41, php 5.2.3, phpMyAdmin 2.10.3 (auch andere versionen testweise installiert aber wieder deinstalliert).
WaldschratMX
 
Posts: 2
Joined: 14. August 2007 04:11

Postby Wiedmann » 14. August 2007 10:14

Wo befindet sich die libmysql.dll?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby WaldschratMX » 14. August 2007 14:06

in c:\windows wenn ich mich recht erinner. kann grad nich nachgucken da auf arbeit

edit: sollte vll anmerken das ich die libmysql.dll auch im verzeichnis ../php/ext , ../php/extensions , ../php , ../windows/system32 , ../windows/ext und im ../apache/dll ordner hatte

momentan nur noch c:/windows (ziemlich sicher das die da is) und im apache/dll
WaldschratMX
 
Posts: 2
Joined: 14. August 2007 04:11

gleiche Fehlermeldung

Postby jweb » 24. August 2007 07:31

hallo
ich habe auch diese Fehlermeldung das die Erweiterung mysql nicht geladen werden kann.
Ich habe die InstallerVersion auf einem WinXP installiert.
Die XAMPP Homepage sieht schon anders aus als bei PHP4 und phpMyAdmin bringt die Fehlermeldung !

Wenn ich nach PHP4 switche geht alles ohne Problem.

Da ich aber eigentlich PHP5 testen wollte, ist das jetzt Dumm! ;-)

Kann mir jemand sagen ob es bei den Version von XAMPP vor 6.x noch ging mit PHP5 zu arbeiten?


Danke
jweb
 
Posts: 2
Joined: 09. January 2007 13:19


Return to phpMyAdmin

Who is online

Users browsing this forum: No registered users and 2 guests