phpMyAdmin Upgrade-Trottel

Und alles was mit phpMyAdmin seine Verwandtschaft findet hat hier seinen Platz.

phpMyAdmin Upgrade-Trottel

Postby oskar2 » 07. March 2007 11:23

Hallo Leute!
Ich hatte PHPTriad 2-2-1 installiert. Das hat auch alles funktioniert.
Dann hab ich die vorhandene PHP-Version mit Version 4.4.6 ersetzt - lief auch alles wunderbar.
Nun wollte ich noch phpMyAdmin von Version 2.2.1(??) auf die aktuelle Version bringen.
Nun hab ich Trottel aber im Eifer des Gefechts die neue Version (2.10.0.2) einfach über die alte Version
drübergeschrieben. - Man sollte halt zuerst die Dokumentation lesen :-(
Jedenfalls hab ich nun erstmal die config.sample.inc.php als config.inc.php verwendet.
Da bekomme ich aber die Meldung "Fehler! Ab sofort muss ein geheimes Passwort zur Verschlüsselung
in der Konfigurationsdatei gesetzt werden (blowfish_secret)." Da hab ich nun was eingetragen,
aber jetzt fragt er mich nach username und passwort. Passwort ist ja vielleicht das aus blowfish_secret
(oder nicht?) aber username hab ich ja keinen eingegeben.
Mit der alten phpMyAdmin-Version hatte ich gar keinen login (weil ja localhost).
Ist da noch was zu retten?
Ich hab auch schon mit $cfg['Servers'][$i]['user'] und $cfg['Servers'][$i]['password'] sowie
$cfg['Servers'][$i]['auth_type'] herumexperimentiert, komme aber nicht richtig weiter.
Ich hab eigentlich keine große Lust, PHPTriad und die neue PHP-Version nochmal zu installieren....
Falls ich neu installieren muß, wie mache ich das Upgrade richtig?

Edit: Ich hab mich schon mal mit diesem threat
http://community.apachefriends.org/f/viewtopic.php?t=22955
befasst, sind wohl aber andere Probleme, hat bei mir zumindest nix gebracht...
oskar2
 
Posts: 2
Joined: 07. March 2007 10:57

Postby oskar2 » 08. March 2007 22:53

...hallo, ist da irgend jemand?.... :?:

...ich werd wohl alles neu installieren.... :cry:
oskar2
 
Posts: 2
Joined: 07. March 2007 10:57

Postby sari42 » 11. March 2007 00:49

guckst du
http://localhost/phpmyadmin/Documentati ... ck_install
oder
http://www.phpmyadmin.net/documentation/#quick_install
oder
http://wiki.cihar.com/pma/Quick_Install#Configuration
Code: Select all
<?php
$i = 0;
$i++;
$cfg['Servers'][$i]['auth_type'] = 'config';
$cfg['Servers'][$i]['user']      = 'deinUser';   
$cfg['Servers'][$i]['password']  = 'dessenPW';
?>
(abgesichert durch .htaccess ;)
sari42
 
Posts: 800
Joined: 27. November 2005 18:28


Return to phpMyAdmin

Who is online

Users browsing this forum: No registered users and 4 guests