Ups-phpMyAdmin 2.5.2 Passwort??

Und alles was mit phpMyAdmin seine Verwandtschaft findet hat hier seinen Platz.

Ups-phpMyAdmin 2.5.2 Passwort??

Postby MAD King » 02. September 2003 11:41

Äh anscheinend habe ich etwas übersehen und komme nicht dahinter. Ich kann mich nicht mehr einloggen:
--------------------------------------------------------------------------------------------------
Willkommen bei phpMyAdmin 2.5.2-pl1 - Login


Ab sofort muss ein geheimes Passwort zur Verschlüsselung in der Konfigurationsdatei gesetzt werden (blowfish_secret).
-------------------------------------------------------------------------------------------------
Wo mache ich das??

Danke
User avatar
MAD King
 
Posts: 82
Joined: 25. July 2003 07:41

Postby Apache-User » 02. September 2003 11:59

config.inc.php

zeile äääämm

60 $cfg['blowfish_secret'] = 'test'; << irgentwas eintragen
mfg
D.A.U.™
User avatar
Apache-User
 
Posts: 594
Joined: 30. December 2002 16:50
Location: anonym

Postby MAD King » 02. September 2003 12:05

Na und wo finde ich diese Datei?
In der Update ist sie nicht.
User avatar
MAD King
 
Posts: 82
Joined: 25. July 2003 07:41

Postby Oswald » 02. September 2003 12:16

User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
XAMPP Version: 5.5.19
Operating System: Linux

Postby MAD King » 02. September 2003 17:24

Kai Seidler wrote:http://www.apachefriends.org/faq-lampp.html#blowfish


Das Problem ist, das XAMPP immer noch auf die config.inc.php zugreift und die Variable in der config.inc-1.2.php steht.
Kann ich die alte config.inc.php löschen und die config.inc-1.2.php in config.inc.php umwandeln?

LOL. Mensch sind das viele config.inc.php.
User avatar
MAD King
 
Posts: 82
Joined: 25. July 2003 07:41

Postby Oswald » 02. September 2003 17:28

Jepp kannst Du! Merk Dir aber die Passwörter, die Du evtl. in der alten config stehen hast.

Gruß,
Oswald
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
XAMPP Version: 5.5.19
Operating System: Linux

Postby MAD King » 02. September 2003 17:54

Hmm Das komische ist, dass ich jetzt ohne irgendwelchen Login auf meine Datenbank zugreifen kann, d.h. jeder der meine phpMyAdmin Seite kennt kann darauf zugreifen.
User avatar
MAD King
 
Posts: 82
Joined: 25. July 2003 07:41

Postby Oswald » 02. September 2003 17:56

Sicher? Nimm mal einen anderen Browser und probiers mit dem. Vermute mal, dass Dein Browser Dein Passwort in einem Cookie gemerkt hat.
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
XAMPP Version: 5.5.19
Operating System: Linux

Postby MAD King » 02. September 2003 18:44

Mhh, wenn ich meine passwort in der config eingebe und phpmyadmin aufrufe komme ich ohne weiteres auf die Seite, kann aber auf keine Datenbank zugreifen.
Was muss ich alles in die config eintragen.
Also die vorhergehende Version hat mir besser gefallen.
User avatar
MAD King
 
Posts: 82
Joined: 25. July 2003 07:41

Postby Oswald » 02. September 2003 20:25

Was kommt denn für eine Fehlermeldung wenn Du auf eine Datenbank zugreifen willst? Oder wenn keine Fehlermeldung kommt: Was passiert genau?
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
XAMPP Version: 5.5.19
Operating System: Linux

Postby MAD King » 02. September 2003 21:03

Fehler

SQL-Befehl :

SHOW TABLE STATUS FROM `xxx`

MySQL meldet:


Access denied for user: '@localhost' to database 'XXX'
User avatar
MAD King
 
Posts: 82
Joined: 25. July 2003 07:41

Postby MAD King » 03. September 2003 17:55

Hallo Oswald,

bitte hilf mir ich muss auf meine Datenbank zugreifen.

Danke

Gruss
User avatar
MAD King
 
Posts: 82
Joined: 25. July 2003 07:41

Postby Kristian Marcroft » 05. September 2003 06:23

Huhu Mad King :)

Ich vermute mal, das irgendetwas mit deiner config.inc.php nicht stimmt.
Kannst du die "alte" mit der "neuen" mal vergleichen?

ggf. meld dich wieder bei mir im IRC, ich schau wieder drüber *g*

So long
KriS
User avatar
Kristian Marcroft
AF Moderator
 
Posts: 2962
Joined: 03. January 2003 12:08
Location: Diedorf

Postby MAD King » 05. September 2003 07:25

Haaallo Kris,

Danke für den Hinweis.
Ich hatte irgendwo eine Variable config die ich dann mit cookie ausgetauscht habe, wie in der alten config und siehe da es geht.

$cfg['Servers'][$i]['auth_type'] = 'cookie'; // Authentication method (config, http or cookie based)?

Oder muss es config sein?

Gruss
User avatar
MAD King
 
Posts: 82
Joined: 25. July 2003 07:41

Postby Apache-User » 05. September 2003 09:54

cookie passt schon ;)
mfg
D.A.U.™
User avatar
Apache-User
 
Posts: 594
Joined: 30. December 2002 16:50
Location: anonym


Return to phpMyAdmin

Who is online

Users browsing this forum: No registered users and 3 guests