problem mit phpMyAdmin

Und alles was mit phpMyAdmin seine Verwandtschaft findet hat hier seinen Platz.

problem mit phpMyAdmin

Postby mATrIxLord » 07. November 2006 18:50

ich habe eine sql datei die 75 MB gross ist. wenn ich sie über phpmyadmin importieren möchte giebt es eine Fehlermeldung. Habe auch schon die FAQ's und dokumente gelesen und auch einiges ausprobiert aber nichts funktioniert bis jetzt. Brauche etwas hilfe. Vielen Dank... 8)
mATrIxLord
 
Posts: 15
Joined: 31. October 2006 18:05

Postby DJ DHG » 07. November 2006 19:05

Moin Moin!

Was für eine Fehlermeldung? Was hast du bis jetzt schon ausprobiert?
Mehr details bitte.

Normalerweise können über PHPmyAdmin nur 2MB dumps importiert werden -> PHP einstellung

Bei solch relativ großen Dumps sollte man sowas auch lieber per Konsole machen.

mfg DJ DHG
User avatar
DJ DHG
AF Moderator
 
Posts: 2455
Joined: 27. December 2002 13:50
Location: Kiel

Postby mATrIxLord » 07. November 2006 20:06

ok..... die meldung sagt das ich versucht habe eine zu grosse datei zu importieren und gibt mir einen link an zur dokumentation. Diese dokumentation habe ich mir auch durchgelesen und auch ausprobiert aber bis jetzt hat es missglückt.....
mATrIxLord
 
Posts: 15
Joined: 31. October 2006 18:05

Postby deepsurfer » 07. November 2006 21:06

- welchen LINK ?
- was wurde in diesem LINK beschrieben was bei dir nicht funktioniert ?
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby mATrIxLord » 07. November 2006 21:39

Starting with version 2.7.0, the import engine has been re–written and these problems should not occur. If possible, upgrade your phpMyAdmin to the latest version to take advantage of the new import features.

The first things to check (or ask your host provider to check) are the values of upload_max_filesize, memory_limit and post_max_size in the php.ini configuration file. All of these three settings limit the maximum size of data that can be submitted and handled by PHP. One user also said that post_max_size and memory_limit need to be larger than upload_max_filesize.

also nach der dokumentation sollte man de diese drei einstellungen nachsehen und dementsprechend konfigurieren damit das ganze ding läuft: upload_max_filesize, memory_limit, post_max_size. Ich habe diese auch umgeändert aber es passiert weiter hin nichts...

PD: habe schon eine lösung gefunden für das problem, meine datenbank hatte eine tabelle die als cache arbeitet, als ich dann eine maintenence routine laufen lies wird diese gelehrt und die datenbank ist dann nur noch 1,75 mb gross.... vielen dank für die mühe!!!!! :D
mATrIxLord
 
Posts: 15
Joined: 31. October 2006 18:05

Postby sari42 » 14. November 2006 15:04

besser geht's, wenn man erst den dump hochlädt und von pma lokal verarbeiten läßt:
http://wiki.cihar.com/pma/FAQ_1.16
siehe "$cfg['UploadDir'] feature"

sonst können bei solchen Problemen
http://www.ozerov.de/bigdump.php
oder
http://mysqldumper.de helfen.
sari42
 
Posts: 800
Joined: 27. November 2005 18:28


Return to phpMyAdmin

Who is online

Users browsing this forum: No registered users and 2 guests