phpMyAdmin wird nicht richtig angezeigt

Und alles was mit phpMyAdmin seine Verwandtschaft findet hat hier seinen Platz.

phpMyAdmin wird nicht richtig angezeigt

Postby jack_php » 22. October 2006 09:33

Hallo Zusammen,

habe auf einem Debian System phpmyadmin installiert, wenn ich aber phpmyadmin aufrufen will (http://meine_ip_adresse/phpmyadmin)
wird nur der inhalt des ordners statt die Weboberfläche angezeigt.

Hoffe ihr könnt mir bei diesem Problem helfen.

Edit:
hab mittlerweile das problem lokalisiert, die php installation ist nicht in ordnung, da nichtmal phpinfo() geht.
Hab schon die neueste Version kompiliert und gemäß den installationsanleitungen konfiguriert (bei apache das php modul aktiviert)
allerdings geht es immer nocht nicht..weiß jemand rat?????


Edit#2:
unter /usr/local/apache2/modules fehlt die libphp5.so
hab schon tausend mal kompiliert aber immer fehlt die libphp5.so..
kann mir den keiner helfen?


Gruß
jack_php
 
Posts: 2
Joined: 21. October 2006 20:48

Postby sari42 » 29. October 2006 11:51

warum installierst du nicht einfach xampp ;)
dann funktioniert's jedenfalls.
sari42
 
Posts: 800
Joined: 27. November 2005 18:28

Re:

Postby jack_php » 29. October 2006 21:29

hab ich mittlerweile:-)

aber jetzt hab ich ein neues problem...
wenn ich mysql aufrufe geht das nicht, da kommt folgende meldung:

ERROR 2002: Can't connect to local MySQL server through socket '/opt/lampp/var/mysql/mysqld.sock' (2)

wenn ich jedoch mysql mit der option -p aufrufe gehts!

und noch ein problem, wenn das perl script von den hlstats starten will, kommt folgende meldung:

DBI connect('hlstats:localhost','root',...) failed: Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' (2) at ./hlstats.pl line 13 31

Can't connect to MySQL database 'hlstats' on 'localhost'
Server error: Can't connect to local MySQL server through socket '/var/run/mysql d/mysqld.sock' (2)


weiß jemand rat?

bin über jede antwort erfreut
jack_php
 
Posts: 2
Joined: 21. October 2006 20:48

Postby sari42 » 02. November 2006 12:43

vielleicht noch nachwehen deiner ersten versuche?
als notlösung kannst du localhost durch 127.0.0.1 ersetzen
(mysql verwendet dann tcp/ip statt sockets).
besser sockets zum laufen bringen, z.b chmod (777 zum testen)
sari42
 
Posts: 800
Joined: 27. November 2005 18:28


Return to phpMyAdmin

Who is online

Users browsing this forum: No registered users and 2 guests