Sicherheitslücke im Apache 2.0.49 (Patch für XAMPP win32)

Hier gibt es Neues und Ankündigen zu XAMPP.
Dieses Forum ist identisch mit der NEWS-Rubrik der Website. Nur kann hier auch was gesagt werden.

Sicherheitslücke im Apache 2.0.49 (Patch für XAMPP win32)

Postby kvo » 29. June 2004 21:55

Nachdem Oswald schon so fleißig war, kommt nun auch der Patch für den Apache 2.0.49 (nur) für die Versionen 1.4.2 und 1.4.3. Zum Download über die win32 XAMPP Seite oder direkt über http://www.apachefriends.org/winxampp/patch2049.zip.
User avatar
kvo
Apache Friends
 
Posts: 184
Joined: 24. January 2003 14:03
Location: Berlin

Postby steini » 29. June 2004 22:17

huhu,

gute arbeit ;).. auf jedenfall als M$ es machen würde *lob*
V-Server ab 7,90€ bei simplyroot
---
Image
User avatar
steini
 
Posts: 191
Joined: 24. October 2003 00:24
Location: Helmstedt
XAMPP Version: 5.6.3
Operating System: Windows 10 Tech Preview

Frage zur Versionsnummer

Postby redscorpio » 02. July 2004 17:13

Hi,

obwohl ich den Patch auf Apache 2.0.50 eingespielt habe (nach einem Update von xampp 1.4.2 auf 1.4.3) zeigt mit die Error Page z.b. bei einem falschen Link mit error 404 folgendes an:
...Apache/2.0.49 (Win32) mod_ssl/2.0.49 OpenSSL/0.9.7d PHP/4.3.7 mod_autoindex/color Server at io Port 80...

Wie kommt das denn? Fehlt was in dem Patch? Ich hatte in laut Anleitung einfach in des schon vorhandene Apache- Verzeichnis kopiert...

Übrigens zeigt auch die xampp\Komponenten-Seite noch die Versionnummern aus 1.4.2 :-(

Hat jemand eine Idee???

Danke
Thomas
User avatar
redscorpio
 
Posts: 3
Joined: 02. July 2004 12:24
Location: Berlin

Re: Frage zur Versionsnummer

Postby Kristian Marcroft » 02. July 2004 20:44

redscorpio wrote:Apache/2.0.49 (Win32) mod_ssl/2.0.49 OpenSSL/0.9.7d PHP/4.3.7 mod_autoindex/color Server at io Port 80...

Wie kommt das denn? Fehlt was in dem Patch? Ich hatte in laut Anleitung einfach in des schon vorhandene Apache- Verzeichnis kopiert...

HI,

wo steht denn das es der Apache 2.0.50 ist?
WIr haben gepatched bevor der Apache 2.0.50 überhaupt erschienen ist.
Somit bleibt es bei Apache 2.0.49 bis ein Update KEIN Patch erscheint.

So long
KriS
User avatar
Kristian Marcroft
AF Moderator
 
Posts: 2962
Joined: 03. January 2003 12:08
Location: Diedorf

Postby redscorpio » 02. July 2004 22:33

OK, das mit der Apache Version ist jetzt klar. Danke für die Antwort. :-)
Noch eine andere Frage: Wie wird denn die Liste der Komponenten auf den mitgelieferten xampp-Seiten generiert?
Die sieht bei mir so aus:
....
Apache 2.0.48, MySQL 4.0.17, PHP 4.3.4, Perl 5.8.2, FileZilla FTP Server 0.8.7, phpMyAdmin 2.5.5 pl1, OpenSSL 0.9.7c, Freetype2 2.1.0, Webalizer 2.01, mod_perl 1.99_12, Turck MMCache 2.4.6, mcrypt 2.5.7, SQLite 2.8.11, JpGraph 1.14 Mercury Mail Transport System PHPBlender PHP Compiler
...

Hier müßten doch z.B. Apache 2.0.49 und PHP 4.3.7 stehen !?
Wie gesagt; ich habe jetzt xampp 1.4.3 mit dem Apache-Patch installiert...

Thomas
User avatar
redscorpio
 
Posts: 3
Joined: 02. July 2004 12:24
Location: Berlin


Return to Ankündigungen und Neuigkeiten

Who is online

Users browsing this forum: No registered users and 1 guest