Zugriff auf mehrere Verzeichnisse (und von mehreren Usern?)

Alles, was den ProFTPD betrifft, kann hier besprochen werden.

Zugriff auf mehrere Verzeichnisse (und von mehreren Usern?)

Postby APieroth » 30. October 2004 15:44

Hallo,

ich habe mir 1. XAMPP unter Suse Linux 9.1 installiert :D , um einen Webserver zum Testen meiner Internetseiten zu haben
und bin 2. blutiger Linux Anfägner. :oops:

ProFTPD ist ja nun standardmäßig so konfiguriert, dass ein Zugriff per FTP nur auf das Verzeichnis /opt/lampp/htdocs möglich ist. Das ist zwar im Prinzip ganz fein, ich möchte jedoch ausserdem noch per FTP auf das Verzeichnis /opt/lampp/cgi-bin zugreifen.
Welche Einstellungen muss ich dazu in der pftpd.conf vornehmen?

Und wenn ich nun mehrere FTP User einrichten möchte, die auf jeweils verschiedene Verzeichnisse zugreifen, wie geht das dann? Nur mittels MySQL oder gibt es da auch eine "einfache" Lösung? :?:

Grüße
APieroth
APieroth
 
Posts: 1
Joined: 16. September 2004 11:43
Location: Bremen

Postby Antivirus » 05. November 2004 19:27

Die meinsten Webspace-Anbieter haben dieses Problem so gelöst:

Das Homeverzeichnis (z.B. User3321) enthält ein cgi-bin Verzeichnis wie alle anderen User auch.

z.B. so

cgi --- hier sind die scripte
html --- die Webseite (.html, .php, usw.)
logs --- normale Logs
stats --- je nach Anbieter auch noch Statistiken


Wenn sich der Kunde einlogt kann er alles anschauen und uploaden. Wenn aber du dich in dein ftp-login einlogt siehst kannst du gleich die .html Dateien uploaden und brachst nicht noch ins html-Verzeichnis zu wechseln.

Jetzt zum Punkt:
Das mit dem cgi-bin-Verzeichnis wird über die Apache-Config gelöst. Genauso das Webverzeichnis der Apache weiss das bei diesem User die .html Dateien im html-Verzeichnis sind. Beim FTP ist es ein normales Home-Verzeichnis welches auf das ganze zugriff hat.

Was du machen musst:
Erstelle einen User (z.B. /home/user1 mit nologin) und füge 2 Verzeichnise hinein:

cgi-bin
html

Proftpd-config

Code: Select all
ServerName "Linux-FTP-Server"
ServerType standalone
DefaultServer on
Port 21
Umask 022
MaxInstances 30
User nobody
DefaultRoot ~
<Directory />
AllowOverwrite on
</Directory>



Jetzt must du die Apache-Config anpassen (httpd.conf):

Code: Select all
NameVirtualHost *:80

#User 1
<VirtualHost *:80>
    ServerName localhost:80
    DocumentRoot "/home/user1/html"
    <Directory "/home/user1/html">
        Order Allow,Deny
        Allow from all
        #Options All
        AllowOverride All
    </Directory>
    <Location /cgi-bin>
        AllowOverride None
        Options +ExecCGI -Includes
        SetHandler cgi-script
    </Location>
</VirtualHost>

#User 2
<VirtualHost *:80>
    ServerName site2.local:80
    DocumentRoot "/home/user2/html"
    <Directory "/home/user2/html">
        Order Allow,Deny
        Allow from all
        #Options All
        AllowOverride All
    </Directory>
    <Location /cgi-bin>
        AllowOverride None
        Options +ExecCGI -Includes
        SetHandler cgi-script
    </Location>
</VirtualHost>


Ich hoffe es klappt, reload oder neustarten nicht vergessen.
der ProFTP-User muss auf das Verzeichnis /home/user1, resp. user2 zugreifen. Wenn du dich einlogst solltest du 2 Verzeichnisse sehen.

Wenns nicht klappt bitte melde dich wieder.

Gruss Antivirus
User avatar
Antivirus
 
Posts: 124
Joined: 11. April 2003 19:33


Return to ProFTPD

Who is online

Users browsing this forum: No registered users and 3 guests