Warum darf ich nicht löschen?

Alles, was den ProFTPD betrifft, kann hier besprochen werden.

Warum darf ich nicht löschen?

Postby Skrelpawin » 12. March 2005 09:17

Hallo zusammen,

ich hab schon einige Versuche unternommen, aber nix hilft.
Vieleicht hat ja einer von euch die Lösung für mich.
Ich habe ein FTP-Verzeichnis (/srv/ftp/) mit zwei Unterordnern,
INCOMING und PUB.
Ich habe es bereits geschafft, dass sich anonyme User im PUB-Verzeichnis umsehen könne und in INCOMING uploaden können, ohne die Dateien hinterher zu sehen/downzuloaden.
Was auch klappt ist, dass sich ein angemeldeter User die Dateien in INCOMING ansehen kann und in PUB und INCOMING uploaden kann.
Was mit noch fehlt ist, dass angemeldete User im INCOMING-Verzeichnis auch Dateien von anonymen Benutzern löschen kann. Dies klappt nämlich nicht.
Hier mal meine Config:

Code: Select all
ServerName "FTP-Server"
ServerType standalone
DefaultServer on

# Port 21 is the standard FTP port.
Port 21

# Umask 022 is a good standard umask to prevent new dirs and files
# from being group and world writable.
Umask 022

# Note that this ONLY works in standalone mode
MaxInstances 30

# Set the user and group under which the server will run.
User nobody
Group nogroup

# To cause every FTP user to be "jailed" (chrooted) into their home
# directory, uncomment this line.

DefaultRoot /srv/ftp

# Our "basic" anonymous configuration, including a single
# upload directory ("uploads")
<Anonymous /srv/ftp>

  # Allow logins if they are disabled above.
  <Limit LOGIN>
    AllowAll
  </Limit>

  # Maximum clients with message
  MaxClients                    5 "Sorry, max %m users -- try again later"

  User                          nobody
  Group                         nogroup
  # We want clients to be able to login with "anonymous" as well as "nobody"
  UserAlias                     anonymous nobody

  # Limit WRITE everywhere in the anonymous chroot
  <Limit WRITE DELE>
    Order allow,deny
    AllowUser test
    DenyAll
  </Limit>

  # An upload directory that allows storing files but not retrieving
  # or creating directories.
  <Directory /srv/ftp/incoming/*>
    <Limit ALL>
      Order allow,deny
      AllowUser test
    </Limit>

    <Limit READ DIRS DELE WRITE SITE_CHMOD MKD RMD LOGIN>
      Order allow,deny
      AllowUser test
      DenyAll
    </Limit>

    <Limit STOR>
      AllowAll
    </Limit>
   
    AllowOverwrite off
    DeleteAbortedStores off
    HiddenStor on

  </Directory>
</Anonymous>


Wie gesagt, ich hab keine Idee mehr. Vielen Dank im Vorraus für eure Hilfe.

Grüße,
Skrelpawin
Skrelpawin
 
Posts: 2
Joined: 02. December 2004 09:35

Postby deepsurfer » 18. March 2005 17:49

setz in der directiven für den icomming doch einen weiteren user ein mit der berechtigung alles zu dürfen.

deine config beschreibt immer einen zugang vom user "test", dieser darf dann nur jenes oder welches, einfahc einen anderen usernamen hinzufügen mit mehr berechtigungen.
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
XAMPP Version: 5.6.3
Operating System: Win-XP / Win7 / Linux -Debian


Return to ProFTPD

Who is online

Users browsing this forum: No registered users and 3 guests