Falsche Dateirechte bei Dateiupload auf Linux FTP

Alles, was den ProFTPD betrifft, kann hier besprochen werden.

Falsche Dateirechte bei Dateiupload auf Linux FTP

Postby marcsabo » 21. February 2005 10:33

Guten Tag,

ich habe eine Frage bezüglich des oben genanten Themas.
Zuvor muss gesagt sein das ich von Linux nicht allzu viel verstehe, wäre also für jeden guten Rat echt dankbar.

Ich besitze einen Linux Enterprise 8.0 Server auf diesem läuft webmin 1.140 mit dem dazugehörigen apache und ftp Server.
Ich habe einen FTP User eingerichtet dieser hat volle Zugriffsrechte auf sein home Verzeichnis.
Wenn ich nun Versuche per FTP-Client mit deisem USer eine HTML Seite hochzuladen, funktioniert dieses reibungslos. Die Datei hat jedoch die Rechte 700, beim Aufrufen meiner denic Domain erscheint jedoch dann der Fehler 403 forbidden.... wenn ich die Dateirechte über den FTP-Client via CHMOD Befehl auf 755 setze, funktioniert wieder alles und die Seite kann angezeigt werden.

Nun meine Frage, kennt jemand eine Möglichkeit das Dateien die Über den FTP User hochgeladen werden. Automatisch mit den rechten 755 versehen werden.
Ist das eine Fehlkonfiguration im Apache oder FTP Server ?

Mit freundlichen Grüßen
Marc
marcsabo
 
Posts: 5
Joined: 21. February 2005 09:17

Postby Kristian Marcroft » 21. February 2005 12:10

Hi,

es ist eine Fehlkonfiguration im FTP Server...
Verwendest du den ProFTPd?

Wenn ja schaun mal in die config...
Dort müsste es irgendwas mit umask geben oder so?
Auf was für einem wert steht das?
AFAIK sollte es auf 022 stehen, damit du 755 bekommst....

Erklärung:

Volle rechte = 777
UMask wird subtrahiert, du willst 755
Also ergibt die uMask: 777 - 755 = 022

So long
KriS
User avatar
Kristian Marcroft
AF Moderator
 
Posts: 2962
Joined: 03. January 2003 12:08
Location: Diedorf

Postby marcsabo » 21. February 2005 13:30

Dank dir schonmal Kristian für die schnelle Antwort.
Ich werde es nachschauen und dann sofort hier posten

mfg
marc
marcsabo
 
Posts: 5
Joined: 21. February 2005 09:17

Postby marcsabo » 23. February 2005 09:25

Hallo,

hab mal neue Infos zusammen getragen.

Der Ftp-Server ist vsftp. Habe über webmin einen User Account mal auf umask 022 umgestellt.

Gleich mal testen ob es funktioniert.

mfg
marc
marcsabo
 
Posts: 5
Joined: 21. February 2005 09:17

Postby marcsabo » 23. February 2005 09:39

So, hab in der /etc/vsftpd.conf den Parameter
local_umask auf 022 gesetzt 077 is dort default.
(Nur bei vsftpd so ;()
und den xinetd neu gestartet.
Jetzt sollte wieder alles zur Kundenzufiredenheit laufen :D.

mfg
marc
marcsabo
 
Posts: 5
Joined: 21. February 2005 09:17

Postby Kristian Marcroft » 23. February 2005 14:23

marcsabo wrote:Jetzt sollte wieder alles zur Kundenzufiredenheit laufen :D.

Hi,

sollte?
Tut es das denn jetzt auch?

So long
KriS
User avatar
Kristian Marcroft
AF Moderator
 
Posts: 2962
Joined: 03. January 2003 12:08
Location: Diedorf

Postby marcsabo » 28. February 2005 16:44

Hallo Kristian,


ja es funktioniert definitiv.

mfg
marc
marcsabo
 
Posts: 5
Joined: 21. February 2005 09:17


Return to ProFTPD

Who is online

Users browsing this forum: No registered users and 1 guest