undefined symbol 'X509_free' & more...

Allgemeines Forum zum Thema Apache Friends. Bei Problemen mit XAMPP bitte entweder das Linux- oder das Windows-Forum benutzen. Hier geht's wirklich nur ganz allgemein um Apache Friends. undefined symbol 'X509_free' & more...

Postby chuckx » 17. November 2004 06:24


I am trying to get SSL working on my webserver, but no luck yet. Tried loads of things, and managed to narrow the error messages down to these:

# apachectl startssl
/usr/local/apache2/bin/httpd:/usr/local/apache2/modules/ undefined symbol 'X509_free'
/usr/local/apache2/bin/httpd: /usr/local/apache2/modules/ can't resolve reference 'X509_free'
/usr/local/apache2/bin/httpd:/usr/local/apache2/modules/ undefined symbol 'X509_INFO_free'
/usr/local/apache2/bin/httpd: /usr/local/apache2/modules/ can't resolve reference 'X509_INFO_free'
/usr/local/apache2/bin/httpd:/usr/local/apache2/modules/ undefined symbol 'CRYPTO_set_mem_functions'
lazy binding failed!
Memory fault (core dumped)

OpenBSD 3.5 GENERIC#34 i386

In my httpd.conf file i have this:
LoadModule ssl_module modules/

and in my modules dir i have this:
-rwxr-xr-x 1 root wheel 513012 Nov 17 13:02

httd-l shows this:
# httpd -l
Compiled-in modules:

but when i go to http://localhost/server-info
mod_ssl is not showing as loaded, or is loading, so thats why im trying to load it manually and get SSL running.

Does anyone know hwo to fix this?

Posts: 3
Joined: 17. November 2004 06:15

Postby Kristian Marcroft » 17. November 2004 12:03


have you created a certificate?
This problem might be caused because there is no certificate found.

And have you got an SSL Section in your httpd.conf?
where it says it should bind to Port 443?

So long
User avatar
Kristian Marcroft
AF Moderator
Posts: 2962
Joined: 03. January 2003 12:08
Location: Diedorf

Postby chuckx » 18. November 2004 07:55

Yep, i created certificates and all that, but mod_ssl wasn't loading.

I couldn't fix it the way i wanted to, so i just ended up recompiling apache completely with options such as

--enable-module=ssl --enable-ssl

So now it works, mod_ssl loads. The next bit now is getting ssl to work, but hopefully that will be pretty easy.

Posts: 3
Joined: 17. November 2004 06:15

Return to Apache Friends

Who is online

Users browsing this forum: No registered users and 1 guest