Java version in apache

Allgemeines Forum zum Thema Apache Friends. Bei Problemen mit XAMPP bitte entweder das Linux- oder das Windows-Forum benutzen. Hier geht's wirklich nur ganz allgemein um Apache Friends.

Java version in apache

Postby apapg » 13. February 2015 01:38

Hi, i would like to ask whether java version in apache server will impact the application running well. Reason we have two apache servers (serve as web server), serverA running fine, but serverB has some problem on application side. i wonder it caused by java version in apache server.


serverA
java -version
java version "1.4.2"
gij (GNU libgcj) version 4.1.2 20080704 (Red Hat 4.1.2-55)


serverB
java -version
java version "1.6.0_32"
OpenJDK Runtime Environment (IcedTea6 1.13.4) (rhel-6.1.13.4.el6_5-x86_64)
OpenJDK 64-Bit Server VM (build 23.25-b01, mixed mode)


weblogic application server:
java -version
java version "1.4.2"
gij (GNU libgcj) version 4.1.2 20080704 (Red Hat 4.1.2-54)
apapg
 
Posts: 3
Joined: 13. February 2015 01:29
Operating System: Linux

Re: Java version in apache

Postby Altrea » 13. February 2015 05:56

We can not answer that question.
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8293
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: Java version in apache

Postby apapg » 13. February 2015 07:13

Or Java is depend to client browser. i would like to ask whether apache web server require java
apapg
 
Posts: 3
Joined: 13. February 2015 01:29
Operating System: Linux

Re: Java version in apache

Postby Altrea » 13. February 2015 10:30

No, Apache httpd don't require Java
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8293
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: Java version in apache

Postby apapg » 13. February 2015 16:10

Thanks :D
apapg
 
Posts: 3
Joined: 13. February 2015 01:29
Operating System: Linux

Re: Java version in apache

Postby hemacarter » 17. September 2015 10:23

Download and install Java. I use JDK 1.7.0_03 and JDK 1.6.0_31, but any Java 6 or 7 version will work. If you will use Java and Tomcat only from within Eclipse you are now done, and you can skip the rest of this page.Set your PATH environment variable to include the Java "bin" directory. Use autoexec.bat or the Control Panel. This step is not needed if you use Java and Tomcat only from within Eclipse.
hemacarter
 
Posts: 1
Joined: 17. September 2015 10:05
Operating System: windows 7


Return to Apache Friends

Who is online

Users browsing this forum: No registered users and 4 guests