Probleme mit Tomcat5.5+ Apache/mod_jk auf Win2k8 R2 64bit

Allgemeines Forum zum Thema Apache Friends. Bei Problemen mit XAMPP bitte entweder das Linux- oder das Windows-Forum benutzen. Hier geht's wirklich nur ganz allgemein um Apache Friends.

Probleme mit Tomcat5.5+ Apache/mod_jk auf Win2k8 R2 64bit

Postby El Admin » 08. October 2010 15:55

Ein freundliches hallo an alle,

ich weiß leider nicht, ob ich mit meinem Problem in diesem Forum überhautpt richtig bin, aber ich muss meine Frage einfach hier mal losweden, weil ich hoffe hier kompetente Webserveradministratoren zu finden.

Mein Problem stellt sich wie folgt dar.
ich habe einen neuen Server, der als webserver eingesetzt werden soll.

BS Windows 2008 R2 (64bit)

ich habe nun zunächst einen Tomcat 5.5.29 installiert, als Dienst eingerichtet und gestartet. Laut log-Datei wurde Catalina-Server gestartet mit den Ports 8005, 8009, 8080. Soweit ist alles schön. Über http://localhost:8080 komme ich auf die Startseite vom Tomcat, auch noch schön.
Nun versuche ich von einem anderen Rechner den Tomcat über seine IP-Adresse aufzurufen, leider kommt dann die Meldung "die Webseite kann nicht angezeigt werden". Ich gehe dann auf <Diagnose von Verbindungsproblemen>, nach der Prüfung bekomme ich die Meldung "die Verbindung wird vom Remotehost oder der Resource nicht akzeptiert".
Firewall kann als Problem ausgeschlossen werden, lokale Firewall ist aus, Firewall zwischen LAN und DMZ ist vom LAN alles offen.

Ich führe auf dem Webserver in der Kommandozeile den Befehl netstat -anp TCP aus und ich bekomme alle offenen Ports angezeigt.
Ich finde die Zeile

Aktive Verbindungen

Proto Lokale Adresse Remoteadresse Status
TCP 127.0.0.1:8005 0.0.0.0:0 ABHÖREN


leider fehlen hier die Zeilen

TCP 0.0.0.0:8009 0.0.0.0:0 ABHÖREN
TCP 0.0.0.0:8080 0.0.0.0:0 ABHÖREN

Wie aber oben schon gesagt kann ich den Tomcat über den Port 8080 im Browser aufrufen. Um noch sicherer zu sein, dass die beiden Ports doch offen sind, habe ich den Telnet-Client aktiviert und prüfe nun damit noch einmal beide Ports.
telnet localhost 8009 - Verbindung erfolgreich
telnet localhost 8080 - Verbindung erfolgreich

Ich habe die Gleiche Konfiguration - server.xml = Standard - auf einem Windows 2003 Server, dort funktioniert das ganze reibungslos. Daher vermute ich das Problem eher beim Windows.

Nun noch mal zusammengefasst die Frage:

Warum sind die beiden Ports nicht als offen angezeigt, obwohl Sie offen sind?

Warum komme ich von einem anderen Rechner nicht auf den Tomcat?


Problem 2:

Nun kommt auch noch der Apache ins Spiel. Ich habe auf der Maschine nun noch einen Apache 2.2.16 laufen und hier zusätzlich das Module mod_jk 1.2.30 eingebunden um Anfragen an Webanwendungen, die im Tomcat laufen darüber an diesen weiterzuleiten.

Beispiel: http://localhost/Tomcatwebanwendung

funktioniert leider auch nicht, ich bekomme die Fehlermeldung "die Webseite kann nicht angezeigt werden"
Apache allein hingegen mit http://localhost funktioniert wieder. :?

Das ganze habe ich schon einige male auf win2k oder win2k3 gemacht hat immer funktioniert

Die worker.properties liegt im Verz. conf, der Pfad dahin ist in der httpd.conf eingetragen


Inhalt worker.properties

worker.list=tomcat1

# ------------------------
# First tomcat server
# ------------------------
worker.tomcat1.port=8009
worker.tomcat1.host=localhost
worker.tomcat1.type=ajp13


ich hoffe, jemand kann mir da helfen
vielen Dank schon mal im voraus


greetings
El Admin
 
Posts: 11
Joined: 23. August 2010 10:24

Re: Probleme mit Tomcat5.5+ Apache/mod_jk auf Win2k8 R2 64bit

Postby El Admin » 20. October 2010 13:41

Hi,

Wieder einmal habe ich mein Problem doch selbst lösen können, leider hat es auch wieder viel Zeit gekostet.
Es stellte sich also heraus, wie ich schon vermutet hatte das Betriebssystem spielt eine Rolle.

Problem 1 ist, bei Win2k8 ist standardmäßig IPv6 aktiviert und hat offensichtlich auch die höhere Priorität vor IPv4.
Einige Dienste von MS verwenden IPv6 und funtionieren nicht mehr wenn das deaktiviert wird. Deaktivieren kann man IPv6 laut MS-Support auch nur über die Systemregistrierung.

Problem 2 ist der Tomcat selbst.
Im Verzeichnis bin vom Tomcat findet man die Datei tc-native-1.dll (last stable version 1.1.20), die offensichtlich immer noch buggy ist. Leider findet man bei Apache keine vernünftige Doku zu dieser Datei, nur soviel dass diese I/O-Funktionen enthält die den Tomcat beschleunigen sollen.

Ich sage immer noch, weil laut Bug-Liste bei Apache ein Problem mit IPv6 schon in früheren Versionen als behoben galt, dem ist offensichtlich nicht so.


Mein Problem habe ich nun so gelöst, dass ich die o.g. Datei aus dem Tomcat entfernt habe, wonach der Zugriff auf den Tomcat von anderen Rechnern oder auch über Apache mit mod_jk funktioniert hat.



Greetings
El Admin
 
Posts: 11
Joined: 23. August 2010 10:24


Return to Apache Friends

Who is online

Users browsing this forum: No registered users and 2 guests

cron