wg. Kompatibilitaet Apache Downgrade auf 1.3?

Allgemeines Forum zum Thema Apache Friends. Bei Problemen mit XAMPP bitte entweder das Linux- oder das Windows-Forum benutzen. Hier geht's wirklich nur ganz allgemein um Apache Friends.

wg. Kompatibilitaet Apache Downgrade auf 1.3?

Postby lwx-amp_user_de » 25. August 2003 11:34

Hallo,

ich muß auf Kompatibilitaet mit den gaengigen Webhostern achten. Kriege ich da mit Apache 2 Probleme? Oder soll ich besser auf Apache 1.3 downgraden? Und worauf muß ich beim Downgrade (Windows / Linux) achten?

Gruss
Rick
lwx-amp_user_de
 

Postby Oswald » 25. August 2003 11:41

Ahoi Rick!

Geht's Dir um Kompatibilität bzgl. PHP, Perl oder CGIs oder um Kompatibilität bzgl. der Konfiguration des Apache?

Eine Apache2-httpd.conf kann man nicht ohne weiteres für Apache-1.3 nutzen. Aus PHP-, Perl- oder CGI-Sicht ist es egal ob Du 1.3 oder 2.0 benutzt.

Lieben Gruß,
Oswald
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
Operating System: Linux

ist schon erledigt

Postby www.christian-esser.de » 25. August 2003 13:55

Hallo ...

habe es nicht mehr ausgehalten, daß andauernd die scripte hingen, und habe es einfach mal gewagt.

GEHT OHNE PROBLEME !!! Einfach 2.0 deinstallieren, danach wieder 1.3 drauf, Verzeichnis HTDOCS wieder füllen, und ein bißchen die config. anpassen...

War in einer 3/4 Stunde gelaufen....

Man muss nur drauf achten, daß die 1.3er Version sich immer in das Verzeichnis c:\apache .... installiert, bei der 2er Version ist es c:\apache2 ... diese Verknüpfungen muss man nur anpassen.

Perl,PHP,Mysql lief alles sofrt wieder normal...

Ergebnis:

Alle scripte laufen einwandfrei, allerdings merkt man jetzt, daß ein 200er Pentium mit 128MB Ram stellenweise am Limit ist, da im Hintergrund noch Webcam und Wetterstation mit Statistik laufen :-).

es hat sich das alte Computer-Fritzen-Sprichwort bewahrheitet:

NEVER CHANGE A RUNNING SYSTEM !!!

Gruß
Christian

www.christian-esser.de
www.christian-esser.de
 

re: Kompatibilitaet

Postby lwx-amp_user_de » 25. August 2003 16:03

Kai Seidler wrote:Ahoi Rick!

Geht's Dir um Kompatibilität bzgl. PHP, Perl oder CGIs oder um Kompatibilität bzgl. der Konfiguration des Apache?

Eine Apache2-httpd.conf kann man nicht ohne weiteres für Apache-1.3 nutzen. Aus PHP-, Perl- oder CGI-Sicht ist es egal ob Du 1.3 oder 2.0 benutzt.

Lieben Gruß,
Oswald


Das es für PHP/Perl egal ist, ist erfreulich. Wie steht es mit der .htaccess und Spielereien mit mod_rewrite?

Gruß
Rick
lwx-amp_user_de
 

Postby Oswald » 25. August 2003 16:08

Auch egal.

Wo es z. B. Unterschiede gibt ist bei VirtualHosts mit der User-Direktive. Oder bei LoadModule/AddModule. Aber das hat ja auch nichts mit .htaccess zu tun.

Liebe Grüße,
Oswald
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
Operating System: Linux


Return to Apache Friends

Who is online

Users browsing this forum: No registered users and 1 guest