Search found 1396 matches: chmod

Searched query: +chmod

Return to advanced search

Re: congic.inc.php edit?

TonyVier wrote:sudo chown root:root config.inc.php


That makes it even worse...

Either

sudo chmod 0666 config.inc.php


but it might be possible, that even this command fails. The problem is, you are working with the XAMPP-VM version (why??) and that is installed like a netdrive in a virtually mounted device. Usually the file permissions in network drives are set at mounting time and cannot be changed after (even noot by root).

I recommend to de-install totally the XAMPP-VM version, instead install one of the other "normal" versions (there are at least three or four non-VM versions, only one VM version). These install simply into your /Applications folder and are much easier to handle.
by Nobbie
04. July 2018 10:20
 
Forum: XAMPP für Mac OS X
Topic: congic.inc.php edit?
Replies: 3
Views: 418

congic.inc.php edit?

Hi there -

I'm following a tutorial that first had me set a database password for my root localhost account, then asked me to go to config.inc.php to change it. I have been unsuccessful in doing so.

What have I tried:
1. Editing the file using the command from this Stack Overflow, received 'permission denied':
Code: Select all
sudo nano config.inc.php

https://stackoverflow.com/questions/33515739/editing-the-file-config-inc-php
2. Editing the permissions on the file using this command from a link recommended in the stack overflow:
Code: Select all
chmod 0755 config.inc.php, permission denied

https://blog.elijaa.org/2013/02/18/solve-wrong-permissions-on-configuration-file-should-not-be-world-writable-error-on-phpmyadmin/

I checked with a more knowledgeable friend, who pointed out that I don't own it.
Image


3. So I opened the terminal that comes with XAMPP, but there is nothing in it that behaves like a directory.
Code: Select all
root@debian:~# ls -a
.  ..  .bash_history  .bashrc  .profile  .ssh  bitnami-first-boot-123456
root@debian:~# cd bitnami-first-boot-123456
-bash: cd: bitnami-first-boot-123456: Not a directory



I'm just ... lost. This tutorial, and the udemy course that follows it, all use XAMPP, but I can't seem to edit the file at all. Any thoughts, folks?
by barda
02. July 2018 21:11
 
Forum: XAMPP für Mac OS X
Topic: congic.inc.php edit?
Replies: 3
Views: 418

Re: mod_proxy user-agent im request header ändern

Der Server läuft mit Debian und Plesk, viel mehr als ab und zu "apt-get update" sowie "apt-get upgrade" muss ich nicht machen um den stabil und sicher zu halten. Sonst will ich nicht gross eingreifen dort, die mod_proxy-konfig konnte ich auf in ein Textfeld im Plesk schreiben. Alles ziemlich problemlos.

Vorübergehend kann ich mit dieser "Lösung" noch leben, war schon vorher so, habe nicht extra deswegen (majestic.com-Problem) die Domain mit http://www.domain.xyz auf dem Vserver mit mod_proxy eingerichtet. Beim shared-Hoster ((www.)domain.info.tm) läuft derzeit ein WordPress-System, dort müsste ich dann halt ein paar Sachen migrieren: Domain- sowie interne Webserver-Pfad-Angaben in den konfig-Files, irgendwelche Verzeichnis- und Dateiberechtigungen ("chmod") etc. Ehrlich gesagt gerade null Bock auf sowas! :( Die MySQL-Datenbank läuft auf einer Windows-Server-VM bei einem Kollegen zuhause, weil ich auch "Stored Procedures" und "Views" verwende. (Das ist bei shared-Hostern grundsätzlich nie möglich)

Die .info.tm-Domain hatte ich am Anfang des Projektes, da kostenlos. Später habe ich gemerkt dass

a.) die .info.tm-Domain bei Google nicht problemlos indexiert wird (Obwohl: https://www.google.ch/search?q=site%3Ai ... e&ie=UTF-8 ) - würde wohl tonnenweise Backlinks erfordern oder so? (Bing und Yahoo scheint's hingegen nicht zu stören, aber ich habe es nun in PHP so geschrieben, dass .info.tm nach .xyz umgeleitet wird per 302 falls man, oder ne Suchmaschine, darauf zugreift)

b.) eine .xyz-Domain schlicht professioneller aussieht als .info.tm (noch "bessere" tld's waren leider schon besetzt)


...noch etwas später habe ich für bestimmte Anforderungen eines Kunden einen Vserver gebraucht, so habe ich dann gedacht ich könnte den vorerst auch nutzen um die .xyz-Domain im Hintergrund per mod_proxy auf die alte Domain umzuleiten. Sollte eh mal alles umgekrempelt werden, das WordPress-Frontend habe ich mal durch eine Eigenentwicklung (mit Laravel und Smarty) ausgetauscht.

Der WordPress-Backend-PHP-Code wird dann wohl beim alten shared-Hoster bleiben, und den Content auf den MySQL-Server beim Kollegen schreiben. Da dort Port 3306 für bestimmte IP's und User geöffnet wird, ist eigentlich alles ziemlich von einander losgelöst. So kann ich es wohl vorerst verhindern, das WordPress komplett migrieren zu müssen, und mein Laravel/Smarty-Frontend sonstwo (egal) hosten. -> Einfach im konfig-File (".env") die entsprechenden MySQL-Parameter hinterlegen, und gut ist!

Hätte ich aber den Vserver und die .xyz-Domain von Anfang an gehabt, dann wäre es sicher nicht soweit gekommen! ;) Der aktuelle shared-Hoster ist aber das "geringste Übel" das ich bezüglich shared-Hosting jemals hatte. (In den letzten 12 Jahren sicher 5x gewechselt, aber selber schuld, will halt immer möglichst wenig Geld dafür ausgeben)
by jmar83
28. May 2018 10:51
 
Forum: Apache
Topic: mod_proxy user-agent im request header ändern
Replies: 10
Views: 551

Access XAMP-VM - insall adds-on

Hi all, how do i access the XAMPP files via command line?

I have tried to install the add-ons from Bitnami for prestashop.

In the documentation it says: (ust replace the name of the file.)
cd /opt/lampp/temp
chmod +x ./INSTALLER_FILENAME.sh
./INSTALLER_FILENAME.sh j

However, I cannot access the cd /opt/lampp/temp

is there any alternative route to install the adds-ons please?

Any help would be appreciated.

Thanks
by pavolvasko
11. January 2018 15:11
 
Forum: XAMPP for Mac OS X
Topic: Access XAMP-VM - insall adds-on
Replies: 0
Views: 456

Re: chmod permission denied

waggs wrote:Ich glaube es ist rausgekommen, dass ich noch nicht viel mit Zugriffsrechten zutun hatte. Tut mir leid, wenn ich mich da sehr dämlich angestellt hab.


Das eigentliche Problem ist das effiziente Marketing von Apple. Die lügen natürlich das Blaue vom Himmel herunter, wenn sie behaupten, bei Apple würde einfach immer alles so einfach sein und würde immer laufen und überhaupt wäre OSX das beste und tollste Betriebssystem der Welt und alles andere wäre nichts dagegen.

Das ist natürlich totaler Müll und dient einzig und allein der Tatsache, die heftig überzogenen Preise zu rechtfertigen. Immerhin hat es Apple mit diesem Marketing geschafft, eine wahre Fangemeinde zu bekommen, obwohl genau diese Klientel sich meistens dadurch auszeichnet, überhaupt nicht die geringste Ahnung von Betriebssystemen und Einbettung in Hardware zu besitzen. Das ist im Prinzip nichts wirklich schlimmes, Marketing und Werbung gehört zu unserem Alltag dazu, aber an solchen Problemen wie Deinem erkennen die User dann auf die harte Tour, dass das Apple Gesülze schlicht gelogen ist. Natürlich ist es überhaupt nicht super einfach und geht wie von alleine, eine etwas kompliziertere Software mit den notwendigen Rechten auszustatten und zu installieren. Das ist Expertenwissen, egal ob OSX, ob WIndows oder Linux. Aber Apple will ja auch noch die eingekaufte Hardware überteuert verkaufen, deswegen müssen sie einen entsprechenden Status vorweisen, den sie aber im Prinzip nicht besitzen.

Ich selbst betreibe hier u.a. ein Laptop mit gutem IPS Monitor und 17,3 Zoll, dazu eine 128GB SSD plus 1,5TB HDD, 8GB RAM und alles unter Linux MInt. Linux ist nicht nur sehr stabil, sondern es ist auch die Entwicklungsplattform von Apache, PHP und MySQL (MariaDB). Das Betriebssystem OSX ist eine Linux Variante und erfordert die gleichen Kenntnisse, wie für den Betrieb von Linux notwendig ist. Mein Rechner trägt nicht zu Apples enormer Gewinnmarge bei, ich habe für alles zusammen ca. 650,-€ bezahlt. Dafür bekomme ich bei Apple allenfalls ein größeres iPad.

Deswegen ist das nicht Deine "Dämlichkeit", sondern die vollkommen normale Unkenntnis, wenn man sich zum ersten Mal mit diesen Dingen beschäftigt. Nur rechnet eben der typische Apple Anhänger überhaupt nicht damit, sich jemals mit solchen Dingen beschäftigen zu müssen. Dem Marketing sei Dank. Aber dafür hast Du einen Haufen Geld an Apple überwiesen, weil sie Dich glauben machen, Du hättest das einfachste und beste OS der Welt auf Deinem Rechner. Das ist platt gelogen. Es ist zwar ein gutes OS, aber nichts besonderes. Jede Linux Distribution ist überlegen, denn Linux ist eine Obermenge zu OSX und unterstützt nicht nur eine gigantische Menge kostenloser Softwareprodukte, sondern auch die manngifaltigsten Varianten an Hardware. OSX ist beschränkt auf die paar Geräte, die Apple einkauft und in ihre Rechner einbaut. Warum erkennen das nur so wenige Anwender?
by Nobbie
04. January 2018 21:43
 
Forum: XAMPP für Mac OS X
Topic: chmod permission denied
Replies: 5
Views: 1867

Re: chmod permission denied

Hallo Nobbie,

vielen Dank für deine Geduld mit mir! Ich glaube es ist rausgekommen, dass ich noch nicht viel mit Zugriffsrechten zutun hatte. Tut mir leid, wenn ich mich da sehr dämlich angestellt hab. Dein Vorschlag funktioniert auf jeden Fall. Danke!

Viele Grüße
Waggs
by waggs
04. January 2018 16:32
 
Forum: XAMPP für Mac OS X
Topic: chmod permission denied
Replies: 5
Views: 1867

Re: chmod permission denied

waggs wrote:Also habe ich einfach mal den ganzen XAMPP-Ordner dem Benutzer xampp übergeben


EInfach mal alles kaputt machen... (s.u.). So funktioniert Rechtemanagement nicht. Da laufen doch auch noch vollkommen andere Prozesse als nur Apache.

waggs wrote:Ich nehme mal an, dass ich noch irgendwo einstellen muss, dass die Datenbanken auch vom Benutzer xampp:admin kontaktiert werden müssen, weil ja der gesamte XAMPP-Ordner jetzt diesem Benutzer gehört. Im Config-File der MySQL-Database hab ich da aber nix gefunden.

Edit: Auch nachdem ich die ursprünglichen Rechte wiederhergestellt hatte, lief die MySQL-Datenbank trotzdem nicht mehr.


Nein. Auch falsch.

Erst einmal: einfach nur den temp Ordner mit chmod 0777 für alle schreibbar machen (und sonst nichts, nicht mit Atombomben auf Spatzen schießen und das gesamte Xampp Projekt verbiegen). Und dann sollte es auch schon laufen. Das Problem ist MySQL bei Dir, das läuft (genau wie Apache) auch mit einer eigenen UserID (wahrscheinlich mit "mysql" als User) und jetzt hast Du die Datenbanken unterm Hintern weggezogen, weil Du die Verzeichnisse alle weggenommen hast. Apache und MySQL haben NICHTS miteinander zu tun. Der User xampp ist NUR für Apache gedacht.

P.S.: Group Admin sieht auch nach keiner guten Idee aus; ich würde da eine stinknormale Standardgruppe nehmen (entweder xampp als Gruppe, oder eine Gruppe "users" oder so, was es halt schon gibt) oder so lassen (wie?! - ich habe kein OSX) wie es war. Aber nicht mit übertriebenen Rechten an Apache gehen, das ist nur ein Sicherheitsproblem. Wenn irgendwann mal WordPress mit seinen furchtbaren Plugins (der unsicherste Wahnsinn, den ich je gesehen habe) auf Deinen Rechner soll, kann es sich furchtbar rächen, wenn Apache zuviel darf...
by Nobbie
03. January 2018 17:33
 
Forum: XAMPP für Mac OS X
Topic: chmod permission denied
Replies: 5
Views: 1867

Re: chmod permission denied

Hallo Nobbie,

danke für deine Antwort. Ja Apache ist auf daemon:daemon eingestellt, aber wie schon beschrieben, auch damit hab ich etwas rumgespielt. Vermutlich aber nicht vollständig. Was du schreibst leuchtet ein und die Idee mit dem zusätlichen Benutzer find ich auch gut. Hab ich ausprobiert:

Code: Select all
<IfModule unixd_module>
#
# If you wish httpd to run as a different user or group, you must run
# httpd as root initially and it will switch. 
#
# User/Group: The name (or #number) of the user/group to run httpd as.
# It is usually good practice to create a dedicated user and group for
# running httpd, as with most system services.
#
User xampp
Group admin
</IfModule>


Ich habe im OS den Nutzer xampp angelegt, und die obige Änderung in der Apache Config vorgenommen. xampp ist jetzt Besitzer von htdocs und darf lesen und schreiben. Leider ist dadurch ein neues Problem entstanden. Was die Dateierstellung angeht, kann ich noch nix sagen, aber jetzt können keine Sessioncookies mehr erstellt werden:

  • session_start(): open(/Applications/XAMPP/xamppfiles/temp//sess_c530c606456c546dfc2a0f4cdb13ee01, O_RDWR) failed: Permission denied (13)

Also habe ich einfach mal den ganzen XAMPP-Ordner dem Benutzer xampp übergeben. Dann lässt sich auch die Datei schreiben. Nur: Nach einem Neustart von XAMPP lässt sich keine Verbindung zur Datenbank mehr herstellen. Bei einem Aufruf von PHPmyadmin wird der folgende Fehler gemeldet:

Code: Select all
#2002 - Connection refused — Der Server antwortet nicht (evtl. ist der Socket des lokalen MySQL-Servers nicht korrekt konfiguriert).


Ich nehme mal an, dass ich noch irgendwo einstellen muss, dass die Datenbanken auch vom Benutzer xampp:admin kontaktiert werden müssen, weil ja der gesamte XAMPP-Ordner jetzt diesem Benutzer gehört. Im Config-File der MySQL-Database hab ich da aber nix gefunden.

Edit: Auch nachdem ich die ursprünglichen Rechte wiederhergestellt hatte, lief die MySQL-Datenbank trotzdem nicht mehr.
by waggs
03. January 2018 16:46
 
Forum: XAMPP für Mac OS X
Topic: chmod permission denied
Replies: 5
Views: 1867

Re: chmod permission denied

Apache läuft unter einer UserId (wahrscheinlich "daemon" unter OSX), die nicht genügend Rechte besitzt, "chmod" auf Dateien auszuüben, die nicht dem User daemon gehören. Das ist das Problem. Das bekommst Du auch nicht gelöst unter Apache, dazu müßtest Du entweder Apache als Admin (bzw. root) laufen lassen (das wird nicht empfohlen) oder doch die Dateirechte so setzen, dass jeder sie verändern darf (aber selbst dann wird chmod wahrscheinlich scheitern).

Du mußt vorher auf Betriebssystemebene die notwendigen Rechte setzen und/oder Apache als anderen User laufen lassen. Es ist nicht möglich, dass Apache einfach so überall Dateien hinschreiben und verändern kann (das ist auch klar, denn dann könnte das jeder Prozess eines beliebigen Users). Ich habe mir selbst (unter Linux) die Xampp Umgebung so eingerichtet, dass ich einen User xampp im Betriebssystem eingerichtet habe, habe Apache neu konfiguriert und lasse ihn auch vom User xampp ausführen (das wird in httpd.conf mit der Anweisung "User ...." festgelegt) und habe unter htdocs alle Dateien an den User Xampp vergeben (rekursive alles, was da herumfliegt, inkl. htdocs selbst). Und dann darf Apache im htdocs Ordner machen, was er will.

Dein Versuch, mit der Require Klausel das Problem zu lösen, scheitert daran, dass das falsche Kontext ist. Zum einen ist diese Anweisung für PHP unwirksam, PHP greift direkt auf Dateien zu, nicht via Apache (aber mit derselben UserId daemon bzw. xampp, wenn Du es anpasst), zum anderen ist diese Konfiguration eine andere Ebene, damit wird gesteuert, ob Apache "an sich" bei HTTP Zugriffen auf dieses Verzeichnis zugreifen darf (das ist quasi ein zusätzlicher Schutz), aber wenn das Betriebssystem nicht erlaubt, dass der User daemon da etwas ändern darf, dann hilft alles nichts, dann scheitert jeder Zugriff, egal was da bei Require steht.

P.S.: Genau genommen hat das Problem eigentlich nichts mit Xampp oder Apache an sich zu tun (Apache ist ein Prozess wie jeder andere auch); das ist ein reines Verständnisproblem, wie das Rechtemanagement unter OSX (bzw. Linux) funktioniert. Der einzige Schnittpunkt zu Apache ist die User Anweisung, mit welcher UserID Apache ausgeführt wird. Aber die ganze Logik, wer wieso und was schreiben darf und wer nicht, das hat mit Xampp nichts zu tun.
by Nobbie
03. January 2018 11:22
 
Forum: XAMPP für Mac OS X
Topic: chmod permission denied
Replies: 5
Views: 1867

chmod permission denied

Hallo zusammen,
ich hab eigentlich nix großes vor. Ich will mit PHP ne Datei auf meinen Server schreiben:

Code: Select all
$pfad = 'hier/hin';
chmod($pfad, 0777);
$datei = fopen('hier/hin/test.txt', 'w');
fwrite($datei, 'Hallo Welt!');
fclose($datei);
chmod('hier/hin/test.txt', 0755);
chmod($pfad, 0755);


Leider wirft dieser Code diverse Fehlermeldungen:
  • Warning: chmod(): Operation not permitted
  • Warning: fopen(hier/hin/test.php): failed to open stream: Permission denied
  • Warning: fwrite() expects parameter 1 to be resource, boolean given
  • Warning: fclose() expects parameter 1 to be resource, boolean given
  • Warning: chmod(): Operation not permitted in
  • Warning: chmod(): Operation not permitted in

Die dritte und vierte Warnung ist die logische Folge auf die zweite. Die könnte ich wegbekommen, indem ich allen Schreibrechte auf den Ordner einräume. Das möchte ich aber nicht, weil das eigentlich chmod übernehmen soll. Ich verwende XAMPP lediglich zur Entwicklung, die Software läuft nachher auf einem anderen Server und da brauche ich chmod - da funktioniert das sogar genau so, aber ich möchte nicht jedesmal zum Testen die ganze Seite hochladen, das muss sich doch auch irgendwie in XAMPP einstellen lassen.

Was ich bisher probiert habe:
  • Ordner, Unterordner und enthaltene Dateien im XAMPP-Ordner für alle les- und schreibbar machen (Datei wird erstellt, chmod wird immernoch nicht akzeptiert, nach ner Weile verabschiedet sich MySQL weil es mit den neu vergebenen Rechten nicht klar kommt)
  • Meinen Projektordner im Ordner htdocs für alle les- und schreibbar machen (Datei wird erstellt, chmod wird immernoch nicht akzeptiert)
  • Im Apache Config-File User und Gruppe verändert in den verschiedensten Variationen (ich in Gruppe daemon, ich in Gruppe admin) kein Effekt auf chmod
  • Im Appache Config-File den folgenden Punkt verändert:
    Code: Select all
    # Deny access to the entirety of your server's filesystem. You must
    # explicitly permit access to web content directories in other
    # <Directory> blocks below.
    #
    <Directory />
        AllowOverride All
        Require all granted
    </Directory>

    da stand vorher none und denied
  • Ich hab mir auch die php.ini angesehen, aber da wollte ich nicht zu viel dran rumspielen, um nix kaputt zu machen.

Ich vermute mal der Schlüssel liegt entweder im config-file von apache oder in der php.ini.
Wäre euch dankbar für nen Tipp.

Viele Grüße und schonmal Danke!
Waggs

PS: Ich verwende XAMPP 7.2.0 auf MacOS High Sierra
by waggs
02. January 2018 19:18
 
Forum: XAMPP für Mac OS X
Topic: chmod permission denied
Replies: 5
Views: 1867

Re: New XAMPP-VM idea for the Mac

nifhanif wrote:- when i run svn(on mac) inside vm mount folder, sometime i cant commit or update svn, until i restart finder
- when i open on sublime text editor. file show ._file almost all file have duplicate in (._file). but not show, when i open on finder on mac
- when i edit file on sublime text, require password to save, and on sometime i ca't change file, i'm rename from sublime, it won't afected


This could be related to the file permissions. Could you change the permissions of the files so "others" can also edit them? You can do from the Terminal and running "chmod -R 777 /path/to/your/files"

nifhanif wrote:maybe when create new port forwarding, it automaticaly enable when start xampp-vm, and auto save will be great


That is a great suggestion thanks. We will look into this.

ctestana wrote:I have XAMP VM running smoothly and i can see my website in my browser, but then i mount the files and try to access my htdocs folder but when opening the file nothing was there its all white . Then it popped up saying interuptted connection with a pic of my lamp root folder with an eject button.


We improved the way of mounting files in the latest versions of XAMPP VM. Could you download a new one? If you do not have any data into the VM, you can clean the directory for removing the previous VM "~/.bitnami".
by Beltran
08. December 2017 10:01
 
Forum: XAMPP for Mac OS X
Topic: New XAMPP-VM idea for the Mac
Replies: 41
Views: 24365

Re: New XAMPP-VM idea for the Mac

tsedendamba wrote:This is great job guys.
I need one important thing. That is git or other version control systems.


I would suggest to install it and use it from the OS X VM itself. You can use "apt-get update && apt-get install git" and that way you can use git from the OS X VM terminal.

charled wrote:"Error starting "XAMPP" stack.


We added a specific error in newer versions to detect if your OS X supports the Intel VT-x feature. If not the OS X VM will redirect to download and install the regular XAMPP installer.

davijpmmm wrote:Hi I want to install phalcon on my xampp vm ! I had tried with phalcon official documentation and search on google many times ! But still no luck


Note this is a Linux VM internally. You should follow the guides to install phalcon in XAMPP linux, this thread can help you https://forum.phalconphp.com/discussion ... with-xampp

Code: Select all
git clone https://github.com/phalcon/cphalcon
cd cphalcon/ext
alias phpize=/opt/lampp/bin/phpize
export CC="gcc"
export CFLAGS="-O2 -Wall -fvisibility=hidden -flto -DZEPHIR_RELEASE=1"
phpize --with-php-config=/opt/lampp/bin/php-config
./configure --enable-phalcon
make --silent && sudo make --silent install


devif wrote:
-- I have to reset nobody password to be able to log via FTP
-- I have to create a folder for my website inside htdocs (lets say /htdocs/website) and chmod "website" folder to 777 to be able to upload anything
-- The biggest problem i have is I cannot find a way to choose my ip and therefore my htdoc/website is not accessible from my lan


- That is correct, but we think that mounting the folder in your OS X functionality is a replacement of the FTP client for editing or copying files easily. Could you post how you are using the FTP client?
- If you mount the folder you are able to create it without having to change the permissions. In any case if you need to change them you can run "chown" from the OS X VM terminal.
- You can create a Network Tunnel without enabling "require local". That way you can connect from other machines in your LAN. You will see this in your Network tab "*:8080 -> 80"
by Beltran
08. December 2017 09:51
 
Forum: XAMPP for Mac OS X
Topic: New XAMPP-VM idea for the Mac
Replies: 41
Views: 24365

Re: New XAMPP-VM idea for the Mac

First time user, currently running XAMPP-VM-osx-7.1.11-0-preview-1 on latest OSX; here are my thoughts:

-- I have to reset nobody password to be able to log via FTP
-- I have to create a folder for my website inside htdocs (lets say /htdocs/website) and chmod "website" folder to 777 to be able to upload anything

-- The biggest problem i have is I cannot find a way to choose my ip and therefore my htdoc/website is not accessible from my lan :
xampp: 192.168.64.x
lan devices 192.168.1.x
I tried to modify interface file but it crashes the VM every time and I have to delete ~/.bitnami in order to get going again. Can you add to the panel a way to change the IP; at the moment I cannot test my site on other lan devices and especially my mobile devices or am I doing something wrong ?

Thanks for all our work, XAMPP for mac will be a delight soon Im sure.
by devif
21. November 2017 18:30
 
Forum: XAMPP for Mac OS X
Topic: New XAMPP-VM idea for the Mac
Replies: 41
Views: 24365

XAMPP VM NOT WORKING

Hello everyone,

Is there a way to reinstall XAMPP without saving any changes that I made? I want a complete fresh start, the app is not working and I don't know what to do.

I got in trouble because I changed my PHPMyAdmin password and then it wouldn't let me enter the page anymore. I couldn't edit config.inc.php to change the password because the file was protected.
I was looking to reinstall the application so I could get a fresh start, because I tried deleting xampp and installing it again, but I don't know why it always opens with the same htdocs files that I had, and PHPMyAdmin not letting me to enter.

So anyway, I made things worse. I used these settings because I found that this way I could reinstall it completely new.

sudo /opt/lampp/lampp stop
sudo chmod +x /opt/lampp/uninstall
sudo /opt/lampp/uninstall
sudo rm -R /opt/lampp

But I ended up deleting the lampp folder and I can no longer use XAMPP. There's nothing in the folder, I can't start the services nor can I mount the folder. I just want a fresh start in the application otherwise I'll have to search for an alternative.
by Abbey43
11. October 2017 01:36
 
Forum: XAMPP for Mac OS X
Topic: XAMPP VM NOT WORKING
Replies: 2
Views: 1114

Re: Trying to install xampp on Ubuntu gives error

Hello,
I've just downloaded the xampp-linux-x64-7.1.8-0-installer.run on my Ubuntu 14.04 device.
(I change to the "Downloads" folder, I think it does not matter if I work there, instead of moving the installer to another folder)
After the permissions (chmod 755 xampp-linux-x64-7.1.8-0-installer.run), when I try to run it (sudo ./xampp-linux-x64-7.1.8-0-installer.run), after the corresponding password, I get this error message:
./xampp-linux-x64-7.1.8-0-installer.run: 1: ./xampp-linux-x64-7.1.8-0-installer.run: Syntax error: Unterminated quoted string
Oops. How can this be fixed?
Thanks in advance for the support.
by chalancito
29. August 2017 18:27
 
Forum: XAMPP for Linux
Topic: Trying to install xampp on Ubuntu gives error
Replies: 9
Views: 5345
Next

Return to advanced search